summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfarwayer2018-02-10 17:26:26 +0300
committerfarwayer2018-02-10 17:26:26 +0300
commitb7c6ab97d1c0f5b244e9c9ab35b23d0b2f4906cd (patch)
treede67ad74c2df8e3c6baaff071c976ed228737d66
parent69e234efed91924554ab36dfd2c41589146c0c0d (diff)
downloadaur-b7c6ab97d1c0f5b244e9c9ab35b23d0b2f4906cd.tar.gz
ruby 2.5.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b11ce4ec8eb..2aab27ae3446 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = ruby-httpclient
pkgdesc = Gives something like the functionality of libwww-perl (LWP) in Ruby.
pkgver = 2.8.3
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/nahi/httpclient
arch = any
license = Ruby
depends = ruby
noextract = httpclient-2.8.3.gem
- source = http://rubygems.org/downloads/httpclient-2.8.3.gem
+ source = https://rubygems.org/downloads/httpclient-2.8.3.gem
sha1sums = 531c6db0b5f371e3d029cbfb2f8d743f7eeb5c1b
pkgname = ruby-httpclient
diff --git a/PKGBUILD b/PKGBUILD
index 7423ceb4a133..8a224a7fdd10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,19 @@
_gemname=httpclient
pkgname=ruby-$_gemname
pkgver=2.8.3
-pkgrel=1
+pkgrel=2
pkgdesc="Gives something like the functionality of libwww-perl (LWP) in Ruby."
arch=('any')
url="http://github.com/nahi/httpclient"
license=('Ruby')
depends=('ruby')
-source=(http://rubygems.org/downloads/$_gemname-$pkgver.gem)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
sha1sums=('531c6db0b5f371e3d029cbfb2f8d743f7eeb5c1b')
package() {
cd "$srcdir"
- local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --no-user-install --ignore-dependencies -i \
"$pkgdir$_gemdir" $_gemname-$pkgver.gem
}