summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarry2017-04-12 21:40:49 -0400
committerHarry2017-04-12 21:40:49 -0400
commit4c535ad88972453cb6dfbd9066af01800c7d4d10 (patch)
treed0f9c84ab39d20b26e2dd2810d42d9f44fcf51cf
downloadaur-ruby-httpclient-2.6.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f55d91bd9fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-httpclient-2.6
+ pkgdesc = Gives something like the functionality of libwww-perl (LWP) in Ruby.
+ pkgver = 2.6.0.1
+ pkgrel = 1
+ url = http://github.com/nahi/httpclient
+ arch = any
+ license = Ruby
+ makedepends = rubygems
+ depends = ruby
+ conflicts = ruby-httpclient
+ noextract = httpclient-2.6.0.1.gem
+ source = http://rubygems.org/downloads/httpclient-2.6.0.1.gem
+ sha1sums = f6a18094e9d1154a9c90df90aa2c8518f3837863
+
+pkgname = ruby-httpclient-2.6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4203aeceeea1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: OmeGa <omega [U+0040] mailoo [.] org>
+
+pkgname=ruby-httpclient-2.6
+_gemname=httpclient
+pkgver=2.6.0.1
+pkgrel=1
+pkgdesc="Gives something like the functionality of libwww-perl (LWP) in Ruby."
+arch=('any')
+url="http://github.com/nahi/httpclient"
+license=('Ruby')
+depends=('ruby')
+makedepends=('rubygems')
+conflicts=('ruby-httpclient')
+source=(http://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('f6a18094e9d1154a9c90df90aa2c8518f3837863')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ gem install --no-user-install --ignore-dependencies -i \
+ "$pkgdir$_gemdir" $_gemname-$pkgver.gem
+}
+
+# vim:set ts=2 sw=2 et: