summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReik Keutterling2021-04-17 23:46:36 +0200
committerReik Keutterling2021-04-17 23:46:36 +0200
commit63d7bc0141519280aa7f88fa74e126c0bedebdb2 (patch)
tree734216acb6d50e0063b9f209d27e796c76e50884
parent5fd1a3f0554911eb2552d0dc8eb12299aadd379a (diff)
downloadaur-63d7bc0141519280aa7f88fa74e126c0bedebdb2.tar.gz
updated version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 654df92949f9..8d31ae112cea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = ruby-iniparse
- pkgdesc = A pure Ruby library for parsing INI documents
- pkgver = 1.4.2
+ pkgdesc = IniParse is a pure Ruby library for parsing INI configuration and data files.
+ pkgver = 1.5.0
pkgrel = 1
- url = http://github.com/antw/iniparse
+ url = https://github.com/antw/iniparse
arch = any
license = MIT
depends = ruby
- noextract = iniparse-1.4.2.gem
+ depends = ruby-bundler
+ noextract = iniparse-1.5.0.gem
options = !emptydirs
- source = https://rubygems.org/downloads/iniparse-1.4.2.gem
- sha256sums = 1920345bccaab2e6ffb573add6399273c2a0b9ec463f1dff9126736d86c944de
+ source = https://rubygems.org/downloads/iniparse-1.5.0.gem
+ sha1sums = 739875d41f5d002f41eba8d38eacda4460da8159
pkgname = ruby-iniparse
diff --git a/PKGBUILD b/PKGBUILD
index 555911b72428..6f3ecfb08324 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
-# Maintainer: Christopher Loen <christopherloen at gmail dot com>
+# Maintainer: Reik Keutterling <spielkind at gmail dot com>
-_gemname_='iniparse'
-pkgname="ruby-${_gemname_}"
-pkgver='1.4.2'
+_gemname=iniparse
+pkgname=ruby-$_gemname
+pkgver=1.5.0
pkgrel=1
-pkgdesc='A pure Ruby library for parsing INI documents'
-arch=('any')
-url='http://github.com/antw/iniparse'
-license=('MIT')
-depends=('ruby')
+pkgdesc="IniParse is a pure Ruby library for parsing INI configuration and data files."
+arch=(any)
+url="https://github.com/antw/iniparse"
+license=(MIT)
+depends=(ruby ruby-bundler)
options=(!emptydirs)
-source=("https://rubygems.org/downloads/${_gemname_}-${pkgver}.gem")
-noextract=("${_gemname_}-${pkgver}.gem")
-sha256sums=('1920345bccaab2e6ffb573add6399273c2a0b9ec463f1dff9126736d86c944de')
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('739875d41f5d002f41eba8d38eacda4460da8159')
package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
- gem install --ignore-dependencies --no-user-install -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" "${_gemname_}-${pkgver}.gem"
- rm "${pkgdir}/${_gemdir}/cache/${_gemname_}-${pkgver}.gem"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
}