summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Tinio2015-08-14 11:15:00 +0800
committerAaron Tinio2015-08-14 11:15:00 +0800
commitcac7ab3e2c6c52100842baad1f16f61e1fe6d82a (patch)
treebce116d18e9f69f23519411554e7d033f6e4c24e
downloadaur-cac7ab3e2c6c52100842baad1f16f61e1fe6d82a.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..062110cd2ae1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ruby-install-git
+ pkgdesc = Installs Ruby, JRuby, Rubinius, MagLev or mruby.
+ pkgver = 0.5.0.r61.9e97cc9
+ pkgrel = 1
+ url = https://github.com/postmodern/ruby-install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = bash
+ depends = curl
+ depends = tar
+ depends = bzip2
+ depends = gcc
+ optdepends = patch: for specifying any additional patches to apply
+ provides = ruby-install
+ conflicts = ruby-install
+ source = git+https://github.com/postmodern/ruby-install
+ md5sums = SKIP
+
+pkgname = ruby-install-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7fd7dc28231
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Aaron Tinio <aptinio at gmail dot com>
+pkgname=ruby-install-git
+pkgver=0.5.0.r61.9e97cc9
+pkgrel=1
+pkgdesc="Installs Ruby, JRuby, Rubinius, MagLev or mruby."
+arch=('any')
+url="https://github.com/postmodern/${pkgname%-git}"
+license=('MIT')
+depends=('bash' 'curl' 'tar' 'bzip2' 'gcc')
+makedepends=('git')
+optdepends=('patch: for specifying any additional patches to apply')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+}