summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2018-09-10 15:37:35 +0200
committerGilrain2018-09-10 15:37:35 +0200
commitc8df97a46506332f23a9f93da0a40d3da6acf143 (patch)
treed5c21f4f65988041c4d77941a6a529b101e85431
downloadaur-c8df97a46506332f23a9f93da0a40d3da6acf143.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de24e15eb609
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-jekyll-data
+ pkgdesc = A plugin to read _config.yml and data files within Jekyll theme-gems
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/ashmaroli/jekyll-data
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = jekyll
+ noextract = jekyll-data-1.0.0.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/jekyll-data-1.0.0.gem
+ sha256sums = 7cc7d79ef804afff77cc5c35c30173a80cf4ff543480c8195ce6ba8ce983e747
+
+pkgname = ruby-jekyll-data
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..200287fd3bf9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+
+_gemname=jekyll-data
+pkgname=ruby-$_gemname
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A plugin to read _config.yml and data files within Jekyll theme-gems'
+arch=(any)
+url='https://github.com/ashmaroli/jekyll-data'
+license=(MIT)
+depends=('ruby' 'jekyll')
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('7cc7d79ef804afff77cc5c35c30173a80cf4ff543480c8195ce6ba8ce983e747')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install --no-document -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}