summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Goguen2016-10-03 18:54:24 +0100
committerJoel Goguen2016-10-03 18:54:24 +0100
commit004f223aae6564a9fa40887ba13c8266617a10ab (patch)
treebd913a6794c98c7868f5467d31f2a17870aeafe6
downloadaur-004f223aae6564a9fa40887ba13c8266617a10ab.tar.gz
v0.3.4
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD28
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a0234d95004
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Mon Oct 3 17:54:06 UTC 2016
+pkgbase = ruby-jekyll-last-modified-at
+ pkgdesc = A liquid tag for Jekyll to indicate the last time a file was modified.
+ pkgver = 0.3.4
+ pkgrel = 1
+ url = https://rubygems.org/gems/jekyll-last-modified-at
+ arch = any
+ license = MIT
+ makedepends = ruby-rspec
+ makedepends = ruby-yard
+ makedepends = ruby-spork
+ depends = ruby
+ depends = ruby-jekyll
+ noextract = jekyll-last-modified-at-0.3.4.gem
+ source = https://rubygems.org/downloads/jekyll-last-modified-at-0.3.4.gem
+ source = LICENSE
+ sha256sums = 3d6ba0c5c5638d6181dc4fe6c1c7bad150d958e9aec9416b3c70a95bf8ce7d4f
+ sha256sums = eaa1755ff0203e4bbd36f46ed146ea4d1b2dc3348cd1cbd2ab0b2c4bf5fc502d
+
+pkgname = ruby-jekyll-last-modified-at
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..73ecf1a3d0a7
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2014 Garen J. Torikian
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..214b34c79467
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Joel Goguen <contact+aur@jgoguen.ca>
+
+_gemname=jekyll-last-modified-at
+pkgname=ruby-${_gemname}
+pkgver=0.3.4
+pkgrel=1
+pkgdesc="A liquid tag for Jekyll to indicate the last time a file was modified."
+arch=('any')
+depends=('ruby' 'ruby-jekyll')
+makedepends=('ruby-rspec' 'ruby-yard' 'ruby-spork')
+url="https://rubygems.org/gems/${_gemname}"
+noextract=($_gemname-$pkgver.gem)
+license=('MIT')
+source=(
+ "https://rubygems.org/downloads/${_gemname}-${pkgver}.gem"
+ 'LICENSE'
+)
+sha256sums=(
+ '3d6ba0c5c5638d6181dc4fe6c1c7bad150d958e9aec9416b3c70a95bf8ce7d4f'
+ 'eaa1755ff0203e4bbd36f46ed146ea4d1b2dc3348cd1cbd2ab0b2c4bf5fc502d'
+)
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}