summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Valentini2018-03-14 08:25:43 +0100
committerRoberto Valentini2018-03-14 08:25:43 +0100
commitd5e585db7c7511054a0d17407da616ea287a6c17 (patch)
treeac3e3666048c166b9ea727e77a7de52e7cb12c04
downloadaur-d5e585db7c7511054a0d17407da616ea287a6c17.tar.gz
add ruby-json-schema on aur
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..505bc6f22b1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-json-schema
+ pkgdesc = Ruby JSON Schema Validator
+ pkgver = 2.8.0
+ pkgrel = 1
+ url = https://github.com/ruby-json-schema/json-schema
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-addressable>=2.4
+ noextract = json-schema-2.8.0.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/json-schema-2.8.0.gem
+ sha256sums = bf7a949c1b9629097af506900668d4c463f5321b6eefed80c57599aa3c46b185
+
+pkgname = ruby-json-schema
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d0f03afeeb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer Roberto Valentini <valantin89 [at] gmail [dot] com>
+
+_gemname=json-schema
+pkgname=ruby-$_gemname
+pkgver=2.8.0
+pkgrel=1
+pkgdesc='Ruby JSON Schema Validator'
+arch=(any)
+url='https://github.com/ruby-json-schema/json-schema'
+license=(MIT)
+depends=('ruby'
+ 'ruby-addressable>=2.4')
+options=(!emptydirs)
+source=("https://rubygems.org/downloads/${_gemname}-${pkgver}.gem")
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('bf7a949c1b9629097af506900668d4c463f5321b6eefed80c57599aa3c46b185')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install --no-document -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" $_gemname-$pkgver.gem
+ rm "${pkgdir}/${_gemdir}/cache/${_gemname}-${pkgver}.gem"
+}