summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-15 04:17:20 +0300
committerDimitris Kiziridis2020-05-15 04:17:20 +0300
commite1c67f39cb71138b50cd9f84d69ae66626095729 (patch)
tree34a8a56a423c3edf05b090de24fb1b1a9a40ac33
parent82b28d28b9b53b098dcf731059588b0965e26f97 (diff)
downloadaur-e1c67f39cb71138b50cd9f84d69ae66626095729.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc844223833f..9b9e75edbc1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,12 +5,13 @@ pkgbase = ruby-jsonpath
url = https://github.com/joshbuddy/jsonpath
arch = any
license = MIT
- depends = ruby
depends = ruby-multi_json
- noextract = $_gemname-$pkgver.gem
+ noextract = ruby-jsonpath-0.5.0.gem
options = !emptydirs
- source = https://rubygems.org/downloads/jsonpath-0.5.0.gem
- md5sums = b5dd754e81ad2ee39f92e511f50d7ef3
+ source = ruby-jsonpath-0.5.0.gem::https://rubygems.org/downloads/jsonpath-0.5.0.gem
+ source = LICENSE::https://github.com/joshbuddy/jsonpath/raw/master/LICENSE.md
+ sha256sums = 4c7282006de383fb62d8a092e6bec6e7ebfc0b899ad59349a279bc32c76bfb9e
+ sha256sums = f8d08617b73c9c304c8543b9b87e354e02468bd02982ae4406283e7a6e29ec02
pkgname = ruby-jsonpath
diff --git a/PKGBUILD b/PKGBUILD
index 63d984fd2719..1d1d5a23a25d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,17 @@ pkgdesc='Ruby implementation of http://goessner.net/articles/JsonPath'
arch=('any')
url='https://github.com/joshbuddy/jsonpath'
license=('MIT')
-depends=('ruby' 'ruby-multi_json')
+depends=('ruby-multi_json')
options=('!emptydirs')
-source=("https://rubygems.org/downloads/$_gemname-$pkgver.gem")
-noextract=('$_gemname-$pkgver.gem')
-md5sums=('b5dd754e81ad2ee39f92e511f50d7ef3')
+source=("${pkgname}-${pkgver}.gem::https://rubygems.org/downloads/$_gemname-$pkgver.gem"
+ 'LICENSE::https://github.com/joshbuddy/jsonpath/raw/master/LICENSE.md')
+noextract=("${pkgname}-${pkgver}.gem")
+sha256sums=('4c7282006de383fb62d8a092e6bec6e7ebfc0b899ad59349a279bc32c76bfb9e'
+ 'f8d08617b73c9c304c8543b9b87e354e02468bd02982ae4406283e7a6e29ec02')
package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
- gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" ${pkgname}-${pkgver}.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file