summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Lühne2017-10-11 00:24:41 +0200
committerPatrick Lühne2017-10-11 00:24:41 +0200
commit6afa6c782e41e3509f5ce3901c96bacc73310f38 (patch)
tree6cbd3f31c40270c16b71d02271af3a814cb47f54
downloadaur-6afa6c782e41e3509f5ce3901c96bacc73310f38.tar.gz
Initial commit as of ruby-liquid 4.0.0.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a504401162c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ruby-liquid
+ pkgdesc = Liquid markup language. Safe, customer facing template language for flexible web apps.
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://shopify.github.io/liquid/
+ arch = any
+ license = MIT
+ depends = ruby
+ options = !emptydirs
+ source = ruby-liquid-4.0.0.tar.gz::https://github.com/Shopify/liquid/archive/v4.0.0.tar.gz
+ sha512sums = 3aa09813e2c6c3b75b9ab0eb1c11ae83f62e6d3dba19c91d8877bf8162edf867b06fbbc4fc3193116313ff98c1fa964b8a01f0cf58c9fb7ed89338f3bffb9cdb
+
+pkgname = ruby-liquid
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8447300d7072
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Patrick Lühne <patrick-arch@luehne.de>
+
+_gemname=liquid
+pkgname=ruby-$_gemname
+pkgver=4.0.0
+pkgrel=1
+pkgdesc='Liquid markup language. Safe, customer facing template language for flexible web apps.'
+url='https://shopify.github.io/liquid/'
+arch=('any')
+license=('MIT')
+depends=('ruby')
+options=('!emptydirs')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/Shopify/${_gemname}/archive/v${pkgver}.tar.gz)
+sha512sums=('3aa09813e2c6c3b75b9ab0eb1c11ae83f62e6d3dba19c91d8877bf8162edf867b06fbbc4fc3193116313ff98c1fa964b8a01f0cf58c9fb7ed89338f3bffb9cdb')
+
+prepare() {
+ cd ${_gemname}-${pkgver}
+ sed -r 's|~>|>=|g' -i ${_gemname}.gemspec # don't give a fuck about rubys bla bla
+ sed 's|git ls-files -z|find -type f -print0\|sed "s,\\\\./,,g"|' -i ${_gemname}.gemspec
+}
+
+build() {
+ cd ${_gemname}-${pkgver}
+ gem build ${_gemname}.gemspec
+}
+
+package() {
+ cd ${_gemname}-${pkgver}
+ local _gemdir="$(gem env gemdir)"
+ gem install --ignore-dependencies --no-user-install -i "${pkgdir}${_gemdir}" -n "${pkgdir}/usr/bin" ${_gemname}-${pkgver}.gem
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ rm "${pkgdir}/${_gemdir}/cache/${_gemname}-${pkgver}.gem"
+}