summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Lühne2017-11-20 18:26:31 +0100
committerPatrick Lühne2017-11-20 18:26:31 +0100
commitfdba53b28948cbd7139698750f82a693c7a0552b (patch)
treeb243b23f0c647dffbdcafcca6da3243a11b0e434
parent6afa6c782e41e3509f5ce3901c96bacc73310f38 (diff)
downloadaur-fdba53b28948cbd7139698750f82a693c7a0552b.tar.gz
Fix Ruby environment
With “$(gem env gemdir)”, users reported that the gem was installed in their home directory and not the default gem directory. This fixes that by using the default gem installation directory instead.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a504401162c..fd264c143d3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ruby-liquid
pkgdesc = Liquid markup language. Safe, customer facing template language for flexible web apps.
pkgver = 4.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://shopify.github.io/liquid/
arch = any
license = MIT
@@ -11,3 +11,4 @@ pkgbase = ruby-liquid
sha512sums = 3aa09813e2c6c3b75b9ab0eb1c11ae83f62e6d3dba19c91d8877bf8162edf867b06fbbc4fc3193116313ff98c1fa964b8a01f0cf58c9fb7ed89338f3bffb9cdb
pkgname = ruby-liquid
+
diff --git a/PKGBUILD b/PKGBUILD
index 8447300d7072..c61b3672ae4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_gemname=liquid
pkgname=ruby-$_gemname
pkgver=4.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Liquid markup language. Safe, customer facing template language for flexible web apps.'
url='https://shopify.github.io/liquid/'
arch=('any')
@@ -26,7 +26,7 @@ build() {
package() {
cd ${_gemname}-${pkgver}
- local _gemdir="$(gem env gemdir)"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "${pkgdir}${_gemdir}" -n "${pkgdir}/usr/bin" ${_gemname}-${pkgver}.gem
install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"