summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Feuls2016-01-26 16:04:01 +0100
committerCarsten Feuls2016-01-26 16:04:01 +0100
commitc2219a085d6aecc03e7d0b187a7b78637bf7368c (patch)
tree141a0adcf2a4a577d034e5b0af5bedb1459445c8
downloadaur-c2219a085d6aecc03e7d0b187a7b78637bf7368c.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b800cbe430b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Jan 26 15:03:43 UTC 2016
+pkgbase = ruby-liquid-3
+ pkgdesc = A secure, non-evaling end user template engine with aesthetic markup.
+ pkgver = 3.0.6
+ pkgrel = 1
+ url = http://www.liquidmarkup.org
+ arch = any
+ license = MIT
+ depends = ruby
+ noextract = liquid-3.0.6.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/liquid-3.0.6.gem
+ sha512sums = 8ec5baa4b4fd5a49fce968fad4b42b9841c690463be944dc5ba52b016cb70dca90fadd42398a0555b376a665fc79359613055755b5bbb6bb77014d61a2074383
+
+pkgname = ruby-liquid-3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b35d7517eb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Carsten Feuls <archlinux@carstenfeuls.de>
+
+_gemname=liquid
+pkgname=ruby-$_gemname-3
+pkgver=3.0.6
+pkgrel=1
+pkgdesc='A secure, non-evaling end user template engine with aesthetic markup.'
+arch=(any)
+url='http://www.liquidmarkup.org'
+license=(MIT)
+depends=('ruby')
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/MIT-LICENSE" "$pkgdir/usr/share/licenses/$pkgname/MIT-LICENSE"
+}
+sha512sums=('8ec5baa4b4fd5a49fce968fad4b42b9841c690463be944dc5ba52b016cb70dca90fadd42398a0555b376a665fc79359613055755b5bbb6bb77014d61a2074383')