summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2021-08-12 09:38:39 -0400
committerMario Finelli2021-08-12 09:38:39 -0400
commit696c682703f065482b14e7e456cf295916f3a598 (patch)
tree9c9f2043848c04e7897be0786550eed9ef74ba9f
downloadaur-696c682703f065482b14e7e456cf295916f3a598.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD60
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0a8cdb07336
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ruby-logger-application
+ pkgdesc = Add logging support to your application
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/ruby/logger-application
+ arch = any
+ license = RUBY
+ license = custom:BSDL
+ checkdepends = ruby-bundler
+ checkdepends = ruby-rake
+ checkdepends = ruby-test-unit
+ checkdepends = ruby-rspec
+ makedepends = rubygems
+ makedepends = ruby-rdoc
+ depends = ruby
+ options = !emptydirs
+ source = https://github.com/ruby/logger-application/archive/v0.0.2.tar.gz
+ sha256sums = 02b51c2d3d8387dd8491362aa77ba92783b982dfb8be31c749320caecef9dd5b
+
+pkgname = ruby-logger-application
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..137be1925495
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Mario Finelli <mario at finel dot li>
+
+_gemname=logger-application
+pkgname=ruby-$_gemname
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Add logging support to your application"
+arch=(any)
+url=https://github.com/ruby/logger-application
+license=(RUBY custom:BSDL)
+depends=(ruby)
+checkdepends=(ruby-bundler ruby-rake ruby-test-unit ruby-rspec)
+makedepends=(rubygems ruby-rdoc)
+options=(!emptydirs)
+source=(https://github.com/ruby/logger-application/archive/v${pkgver}.tar.gz)
+sha256sums=('02b51c2d3d8387dd8491362aa77ba92783b982dfb8be31c749320caecef9dd5b')
+
+prepare() {
+ cd "$_gemname-$pkgver"
+
+ # running the rspec tests depends on mspec, but the source is gone
+ # and it still depends on rspec 2.8
+ sed -i '/mspec/d' Gemfile
+
+ # we use an archive not a git checkout
+ sed -i 's|git ls-files -z|find -print0|' ${_gemname}.gemspec
+ sed -i 's/%r{^bin\/}/%r{^\\.\/bin\/}/' ${_gemname}.gemspec
+ sed -i 's/%r{^(test|spec|features)\/}/%r{^\\.\/(test|spec|features)\/}/' \
+ ${_gemname}.gemspec
+}
+
+build() {
+ cd "$_gemname-$pkgver"
+ gem build ${_gemname}.gemspec
+}
+
+check() {
+ cd "$_gemname-$pkgver"
+ rake test
+ # rake spec
+}
+
+package() {
+ cd "$_gemname-$pkgver"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+
+ gem install \
+ --ignore-dependencies \
+ --no-user-install \
+ -i "$pkgdir/$_gemdir" \
+ -n "$pkgdir/usr/bin" \
+ $_gemname-$pkgver.gem
+
+ rm -rf "$pkgdir/$_gemdir/cache"
+
+ install -Dm0644 BSDL "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm0644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}
+
+# vim: set ts=2 sw=2 et: