summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorimlonghao2020-07-15 14:08:48 +0000
committerimlonghao2020-07-15 14:08:48 +0000
commit67d2d4243f6aac046b615d45348f16cd2007a403 (patch)
tree01fbc5494650e470bca117c8e64526ffa4d63d2c
parent26a1c1f220a99f4d579060bf4dbe7e231b4b200d (diff)
downloadaur-67d2d4243f6aac046b615d45348f16cd2007a403.tar.gz
New version 2.3.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06b58f7f8c3a..18544410ceab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
-# Generated by mksrcinfo v8
-# Wed Feb 7 10:20:59 UTC 2018
pkgbase = ruby-logging
- pkgdesc = Logging is a flexible logging library for use in Ruby programs
- pkgver = 2.2.2
+ pkgdesc = A flexible and extendable logging library for Ruby
+ pkgver = 2.3.0
pkgrel = 1
- url = https://github.com/TwP/logging/
+ url = http://rubygems.org/gems/logging
arch = any
depends = ruby
- depends = ruby-little-plugger>=1.1
- depends = ruby-multi_json>=1.10
- noextract = logging-2.2.2.gem
+ depends = ruby-little-plugger
+ depends = ruby-multi_json
+ noextract = logging-2.3.0.gem
options = !emptydirs
- source = https://rubygems.org/downloads/logging-2.2.2.gem
- sha512sums = 9eeaec06f61dec5f79b7b656b77504026d6d91baea52594fa508f1587a8300ebb3d5c30461c7b4a41eb86f7b98530e4f6ab7853946fa14f00b84884be780b64a
+ source = https://rubygems.org/downloads/logging-2.3.0.gem
+ sha1sums = b35cf3d50819a51398ff764d0d2a9de689415e2a
pkgname = ruby-logging
diff --git a/PKGBUILD b/PKGBUILD
index f2846fb8d345..21d97771e2da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
-# Maintainer: Carsten Feuls <archlinux@carstenfeuls.de>
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Hao Long <aur@esd.cc>
_gemname=logging
pkgname=ruby-$_gemname
-pkgver=2.2.2
+pkgver=2.3.0
pkgrel=1
-pkgdesc='Logging is a flexible logging library for use in Ruby programs'
+pkgdesc='A flexible and extendable logging library for Ruby'
arch=(any)
-url='https://github.com/TwP/logging/'
-depends=('ruby' 'ruby-little-plugger>=1.1' 'ruby-multi_json>=1.10')
+url='http://rubygems.org/gems/logging'
+license=()
+depends=(ruby ruby-little-plugger ruby-multi_json)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
-sha512sums=('9eeaec06f61dec5f79b7b656b77504026d6d91baea52594fa508f1587a8300ebb3d5c30461c7b4a41eb86f7b98530e4f6ab7853946fa14f00b84884be780b64a')
+sha1sums=('b35cf3d50819a51398ff764d0d2a9de689415e2a')
package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}