summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2016-01-07 21:43:23 -0500
committerMario Finelli2016-01-07 21:46:54 -0500
commit1c48b898c35c7c877f41f37347efd6554be5c2f8 (patch)
tree759a33b683602ada6c89b9eba56d5273f1e6b1cc
downloadaur-1c48b898c35c7c877f41f37347efd6554be5c2f8.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcf40323df85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Fri Jan 8 02:46:42 UTC 2016
+pkgbase = ruby-mechanize
+ pkgdesc = The Mechanize library is used for automating interaction with websites.
+ pkgver = 2.7.4
+ pkgrel = 1
+ url = http://docs.seattlerb.org/mechanize/
+ arch = any
+ license = MIT
+ makedepends = rubygems
+ depends = ruby
+ depends = ruby-domain_name
+ depends = ruby-http-cookie
+ depends = ruby-mime-types
+ depends = ruby-net-http-digest_auth
+ depends = ruby-net-http-persistent
+ depends = ruby-nokogiri
+ depends = ruby-ntlm-http
+ depends = ruby-webrobots
+ noextract = mechanize-2.7.4.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/mechanize-2.7.4.gem
+ sha256sums = 1799d05733a1176a32179a210345a555b9a2bba4d1e2977f17fdcdf114aa6dd2
+
+pkgname = ruby-mechanize
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e51316332d1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Generated with gembuild (https://github.com/mfinelli/gembuild)
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+
+_gemname=mechanize
+pkgname=ruby-$_gemname
+pkgver=2.7.4
+pkgrel=1
+pkgdesc='The Mechanize library is used for automating interaction with websites.'
+arch=('any')
+url='http://docs.seattlerb.org/mechanize/'
+license=('MIT')
+options=(!emptydirs)
+noextract=($_gemname-$pkgver.gem)
+depends=('ruby' 'ruby-domain_name' 'ruby-http-cookie' 'ruby-mime-types' 'ruby-net-http-digest_auth' 'ruby-net-http-persistent' 'ruby-nokogiri' 'ruby-ntlm-http' 'ruby-webrobots')
+makedepends=('rubygems')
+source=("https://rubygems.org/downloads/$_gemname-$pkgver.gem")
+sha256sums=('1799d05733a1176a32179a210345a555b9a2bba4d1e2977f17fdcdf114aa6dd2')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+}