summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Pérez2020-10-01 17:25:11 -0600
committerLuis Pérez2020-10-01 17:25:11 -0600
commit7e012c48de74a1eb7c58227435d1d7f292f465d4 (patch)
treec7f1f4c9092867fac272db1caa938c7e66ceb793
downloadaur-7e012c48de74a1eb7c58227435d1d7f292f465d4.tar.gz
new package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f94a9540f9a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-mini_exiftool
+ pkgdesc = A wrapper for the ExifTool command-line application
+ pkgver = 2.10.0
+ pkgrel = 2
+ url = https://github.com/janfri/mini_exiftool
+ arch = any
+ license = LGPL2.1
+ depends = ruby
+ depends = perl-image-exiftool
+ noextract = mini_exiftool-2.10.0.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/mini_exiftool-2.10.0.gem
+ sha256sums = 1cd78896a4825c7b693ca8e68c1b3b532cef3733df0cac3289a98c66631cb968
+
+pkgname = ruby-mini_exiftool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb87de766c5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Luis Pérez <luis.perez@protonmail.com>
+_gemname=mini_exiftool
+pkgname=ruby-$_gemname
+pkgver=2.10.0
+pkgrel=2
+pkgdesc='A wrapper for the ExifTool command-line application'
+arch=(any)
+url='https://github.com/janfri/mini_exiftool'
+license=('LGPL2.1')
+depends=(
+ 'ruby'
+ 'perl-image-exiftool'
+ )
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+sha256sums=('1cd78896a4825c7b693ca8e68c1b3b532cef3733df0cac3289a98c66631cb968')
+noextract=($_gemname-$pkgver.gem)
+
+package() {
+ local _gemdir="$(ruby -e 'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+}