summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2016-01-07 21:52:47 -0500
committerMario Finelli2016-01-07 21:52:47 -0500
commit4233f81877d72504abedc6730caebbc5d600a211 (patch)
tree0b468d2dbf67df8ec2401cd3d16363541fa0d57b
downloadaur-4233f81877d72504abedc6730caebbc5d600a211.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a3945d97929
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Jan 8 02:52:27 UTC 2016
+pkgbase = ruby-net-http-digest_auth
+ pkgdesc = An implementation of RFC 2617 - Digest Access Authentication.
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://github.com/drbrain/net-http-digest_auth
+ arch = any
+ makedepends = rubygems
+ depends = ruby
+ noextract = net-http-digest_auth-1.4.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/net-http-digest_auth-1.4.gem
+ sha256sums = 11f7a8c13e801455dedd8864339d5fcd6536949b99ec9b3eae193c32f20b0091
+
+pkgname = ruby-net-http-digest_auth
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..398f499cac90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Generated with gembuild (https://github.com/mfinelli/gembuild)
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+
+_gemname=net-http-digest_auth
+pkgname=ruby-$_gemname
+pkgver=1.4
+pkgrel=1
+pkgdesc='An implementation of RFC 2617 - Digest Access Authentication.'
+arch=('any')
+url='http://github.com/drbrain/net-http-digest_auth'
+options=(!emptydirs)
+noextract=($_gemname-$pkgver.gem)
+depends=('ruby')
+makedepends=('rubygems')
+source=("https://rubygems.org/downloads/$_gemname-$pkgver.gem")
+sha256sums=('11f7a8c13e801455dedd8864339d5fcd6536949b99ec9b3eae193c32f20b0091')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+}