summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhenning mueller2015-07-05 19:52:01 +0200
committerhenning mueller2015-07-05 19:52:01 +0200
commit1e01ff2f4ff4fa0e82f4e6303a870c54ecf13574 (patch)
treec8b6437d60aff418d7493cd826a28a00a4060488
downloadaur-1e01ff2f4ff4fa0e82f4e6303a870c54ecf13574.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
3 files changed, 63 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..274fc5f67130
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = ruby-open_uri_redirections
+ pkgdesc = OpenURI patch to allow redirections between HTTP and HTTPS
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/jaimeiniesta/open_uri_redirections
+ arch = any
+ license = MIT
+ makedepends = rubygems
+ depends = ruby
+ source = https://rubygems.org/downloads/open_uri_redirections-0.1.4.gem
+ noextract = open_uri_redirections-0.1.4.gem
+ options = !emptydirs
+
+pkgname = ruby-open_uri_redirections
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..805489dae9ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-open_uri_redirections
+ pkgdesc = OpenURI patch to allow redirections between HTTP and HTTPS
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/jaimeiniesta/open_uri_redirections
+ arch = any
+ license = MIT
+ makedepends = rubygems
+ depends = ruby
+ noextract = open_uri_redirections-0.1.4.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/open_uri_redirections-0.1.4.gem
+ sha256sums = f4ba5f0655ae436e19dbd9c55ef564c3ec17bead89d1d05422417634f41c4c25
+
+pkgname = ruby-open_uri_redirections
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8a9c938f312
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: henning mueller <henning@orgizm.net>
+# Contributor: megadriver <megadriver at gmx dot com>
+
+_gemname=open_uri_redirections
+pkgname=ruby-$_gemname
+pkgver=0.1.4
+pkgrel=1
+pkgdesc='OpenURI patch to allow redirections between HTTP and HTTPS'
+arch=(any)
+url='https://github.com/jaimeiniesta/open_uri_redirections'
+license=(MIT)
+depends=(ruby)
+makedepends=(rubygems)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+
+package() {
+ export RBENV_VERSION=system
+
+ local _gemdir="$(ruby -e 'puts Gem.default_dir')"
+
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" \
+ -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}
+
+sha256sums=('f4ba5f0655ae436e19dbd9c55ef564c3ec17bead89d1d05422417634f41c4c25')