summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Reggiani Manzo2016-02-17 18:51:22 -0200
committerRafael Reggiani Manzo2016-02-17 18:53:59 -0200
commit934f057ac24663991b4c4ff186b136667b867063 (patch)
treef42a9af4ba62e7a1a7b87b4a19f359afce53f943
downloadaur-934f057ac24663991b4c4ff186b136667b867063.tar.gz
Create initial port to AUR4
This has been done with consent from previous maintainer and a upgrade has been made.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19e14e42b7a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Feb 17 20:50:04 UTC 2016
+pkgbase = ruby-opennebula
+ pkgdesc = OpenNebula Client API
+ pkgver = 4.14.2
+ pkgrel = 1
+ url = https://rubygems.org/gems/opennebula/
+ arch = any
+ license = Apache
+ depends = ruby
+ depends = ruby-nokogiri
+ depends = ruby-json
+ noextract = opennebula-4.14.2.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/opennebula-4.14.2.gem
+ sha256sums = 4de7f094471f37ec3f7ec20e581318094ac78d310abb70ec4c30fd1790b38ec7
+
+pkgname = ruby-opennebula
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c078251f83c5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*pkg.tar.xz
+*gem
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a5e209ab763
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Rafael Reggiani Manzo <rr.manzo at gmail dot com>
+# Previous Maintainer: Jason St. John <jstjohn .. purdue . edu>
+
+_gemname=opennebula
+pkgname="ruby-${_gemname}"
+pkgver=4.14.2
+pkgrel=1
+pkgdesc='OpenNebula Client API'
+arch=('any')
+url='https://rubygems.org/gems/opennebula/'
+license=('Apache')
+depends=('ruby' 'ruby-nokogiri' 'ruby-json')
+options=('!emptydirs')
+source=("https://rubygems.org/downloads/${_gemname}-${pkgver}.gem")
+noextract=("${_gemname}-${pkgver}.gem")
+sha256sums=('4de7f094471f37ec3f7ec20e581318094ac78d310abb70ec4c30fd1790b38ec7')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" "${_gemname}-${pkgver}.gem"
+ rm "${pkgdir}/${_gemdir}/cache/${_gemname}-${pkgver}.gem"
+}