summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroliparcol2011-07-12 15:01:00 +0000
committerThomas Dziedzic2011-07-12 15:01:00 +0000
commit55b5cb5f8e50feb449de50b79b7a6731f8ec94c8 (patch)
tree4cb59c1dfd19a9daf762c7c18d9fa6e188ecefb5
downloadaur-55b5cb5f8e50feb449de50b79b7a6731f8ec94c8.tar.gz
updated on Tue Jul 12 15:01:00 UTC 2011
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE28
-rw-r--r--PKGBUILD24
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed757cbf0b3c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ruby-posix-spawn
+ pkgdesc = posix-spawn uses posix_spawnp(2) for faster process spawning
+ pkgver = 0.3.6
+ pkgrel = 1
+ url = https://github.com/rtomayko/posix-spawn
+ arch = any
+ license = MIT
+ makedepends = rubygems
+ depends = ruby
+ noextract = posix-spawn-0.3.6.gem
+ source = http://rubygems.org/downloads/posix-spawn-0.3.6.gem
+ source = LICENSE
+ md5sums = fd3903ab505d19aadbec5d3baa0d9449
+ md5sums = 0c1a6d29e061ff630dc8294b815f28c3
+
+pkgname = ruby-posix-spawn
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b59ba11aaf58
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,28 @@
+Copyright (c) 2011 by Ryan Tomayko <r@tomayko.com>
+ and Aman Gupta <aman@tmm1.net>
+
+Permission is hereby granted, free of charge, to any person ob-
+taining a copy of this software and associated documentation
+files (the "Software"), to deal in the Software without restric-
+tion, including without limitation the rights to use, copy, modi-
+fy, merge, publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software is fur-
+nished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONIN-
+FRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
+LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
+ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
+A small portion of the environ dup'ing code in ext/posix-spawn.c
+was taken from glibc <http://www.gnu.org/s/libc/> and is maybe
+Copyright (c) 2011 by The Free Software Foundation or maybe
+by others mentioned in the glibc LICENSES file. glibc is
+distributed under the terms of the LGPL license.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d36db27c8c13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: oliparcol <oliparcol AT gmail DOT com>
+pkgname=ruby-posix-spawn
+pkgver=0.3.6
+pkgrel=1
+pkgdesc="posix-spawn uses posix_spawnp(2) for faster process spawning"
+arch=(any)
+url="https://github.com/rtomayko/posix-spawn"
+license=('MIT')
+depends=(ruby)
+makedepends=(rubygems)
+source=(http://rubygems.org/downloads/posix-spawn-$pkgver.gem
+ LICENSE)
+md5sums=('fd3903ab505d19aadbec5d3baa0d9449'
+ '0c1a6d29e061ff630dc8294b815f28c3')
+noextract=(posix-spawn-$pkgver.gem)
+
+build() {
+ cd $srcdir
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+
+ gem install --ignore-dependencies -i "$pkgdir$_gemdir" posix-spawn-$pkgver.gem
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}