summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2013-12-30 00:36:13 +0000
committerKyle Keen2013-12-30 00:36:13 +0000
commit982ec36d3559d8e918e7eb14b6d5519c520ee41f (patch)
tree866dd3cb8547aa0a42a2a58c3d6e3ff506eacd4f
parent9de7d28fcf4848ba9d0aaa0556e15bfdd2b003be (diff)
downloadaur-982ec36d3559d8e918e7eb14b6d5519c520ee41f.tar.gz
updated on Mon Dec 30 00:36:12 UTC 2013
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE28
-rw-r--r--PKGBUILD40
3 files changed, 30 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d57d00ac8102..18930facf9c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = ruby-posix-spawn
- pkgdesc = posix-spawn uses posix_spawnp(2) for faster process spawning
- pkgver = 0.3.6
- pkgrel = 2
- url = https://github.com/rtomayko/posix-spawn
- arch = any
+ pkgdesc = posix_spawnp(2) for ruby
+ pkgver = 0.3.8
+ pkgrel = 1
+ url = http://github.com/rtomayko/posix-spawn
+ arch = i686
+ arch = x86_64
license = MIT
- makedepends = rubygems
depends = ruby
- noextract = posix-spawn-0.3.6.gem
- source = http://rubygems.org/downloads/posix-spawn-0.3.6.gem
- source = LICENSE
- md5sums = fd3903ab505d19aadbec5d3baa0d9449
- md5sums = 0c1a6d29e061ff630dc8294b815f28c3
+ noextract = posix-spawn-0.3.8.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/posix-spawn-0.3.8.gem
+ sha1sums = ca26e990432efcaf866651d56c8bf600c38882a2
pkgname = ruby-posix-spawn
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index b59ba11aaf58..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,28 +0,0 @@
-Copyright (c) 2011 by Ryan Tomayko <r@tomayko.com>
- and Aman Gupta <aman@tmm1.net>
-
-Permission is hereby granted, free of charge, to any person ob-
-taining a copy of this software and associated documentation
-files (the "Software"), to deal in the Software without restric-
-tion, including without limitation the rights to use, copy, modi-
-fy, merge, publish, distribute, sublicense, and/or sell copies of
-the Software, and to permit persons to whom the Software is fur-
-nished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be
-included in all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
-OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONIN-
-FRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
-LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
-ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
-CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
-
-A small portion of the environ dup'ing code in ext/posix-spawn.c
-was taken from glibc <http://www.gnu.org/s/libc/> and is maybe
-Copyright (c) 2011 by The Free Software Foundation or maybe
-by others mentioned in the glibc LICENSES file. glibc is
-distributed under the terms of the LGPL license.
diff --git a/PKGBUILD b/PKGBUILD
index d603ab7e7ea2..1274e876f799 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
# Contributor: oliparcol <oliparcol AT gmail DOT com>
-pkgname=ruby-posix-spawn
-pkgver=0.3.6
-pkgrel=2
-pkgdesc="posix-spawn uses posix_spawnp(2) for faster process spawning"
-arch=(any)
-url="https://github.com/rtomayko/posix-spawn"
-license=('MIT')
-depends=(ruby)
-makedepends=(rubygems)
-source=(http://rubygems.org/downloads/posix-spawn-$pkgver.gem
- LICENSE)
-md5sums=('fd3903ab505d19aadbec5d3baa0d9449'
- '0c1a6d29e061ff630dc8294b815f28c3')
-noextract=(posix-spawn-$pkgver.gem)
-
-build() {
- cd $srcdir
- local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
- gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" posix-spawn-$pkgver.gem
+_gemname=posix-spawn
+pkgname=ruby-$_gemname
+pkgver=0.3.8
+pkgrel=1
+pkgdesc='posix_spawnp(2) for ruby'
+arch=(i686 x86_64)
+url='http://github.com/rtomayko/posix-spawn'
+license=(MIT)
+depends=(ruby)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('ca26e990432efcaf866651d56c8bf600c38882a2')
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/COPYING" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}