summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2016-09-07 08:03:14 -0400
committerMario Finelli2016-09-07 08:03:14 -0400
commitaaa75331edcec08840f8db1b42a44e498b6c8d8a (patch)
treefa5f19f28a5f4b6c788af3b928c2d445bb02701f
downloadaur-aaa75331edcec08840f8db1b42a44e498b6c8d8a.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1db91c2bcce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Sep 7 12:00:54 UTC 2016
+pkgbase = ruby-puppet_forge
+ pkgdesc = Ruby client for the Puppet Forge API.
+ pkgver = 2.2.2
+ pkgrel = 1
+ url = https://github.com/puppetlabs/forge-ruby
+ arch = any
+ license = Apache-2.0
+ depends = ruby
+ depends = ruby-faraday
+ depends = ruby-faraday_middleware
+ depends = ruby-semantic_puppet
+ depends = ruby-minitar
+ depends = ruby-gettext-setup
+ noextract = puppet_forge-2.2.2.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/puppet_forge-2.2.2.gem
+ sha256sums = 9ba3c47bccdf97ce511f916b627b3902e02a1913951598b2887437025abc56d4
+
+pkgname = ruby-puppet_forge
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..122d9cef6578
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mario Finelli <mario at finel dot li>
+
+_gemname=puppet_forge
+pkgname=ruby-$_gemname
+pkgver=2.2.2
+pkgrel=1
+pkgdesc='Ruby client for the Puppet Forge API.'
+arch=(any)
+url='https://github.com/puppetlabs/forge-ruby'
+license=('Apache-2.0')
+depends=(ruby ruby-faraday ruby-faraday_middleware ruby-semantic_puppet ruby-minitar ruby-gettext-setup)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('9ba3c47bccdf97ce511f916b627b3902e02a1913951598b2887437025abc56d4')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+}