summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatěj Grabovský2015-11-15 11:08:27 +0100
committerMatěj Grabovský2015-11-15 11:08:27 +0100
commit99f86be2c39146b2c15a5fc25ce2247f8f8da81d (patch)
tree5aa3a927c2730cce91d5502ade3d4763ca340a6e
parent7065aba342e7018b924c8905c6fa387348bee142 (diff)
downloadaur-99f86be2c39146b2c15a5fc25ce2247f8f8da81d.tar.gz
Don't build documentation due to a bug in rdoc
See https://github.com/rdoc/rdoc/issues/361
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ff6f4561d43..1168d89f08fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ruby-rails
pkgdesc = Full-stack web application framework.
pkgver = 4.2.5
- pkgrel = 1
+ pkgrel = 2
url = http://www.rubyonrails.org
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index c56776521753..5b1a6857ff45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,13 @@
_gemname=rails
pkgname=ruby-$_gemname
pkgver=4.2.5
-pkgrel=1
+pkgrel=2
pkgdesc='Full-stack web application framework.'
arch=(any)
url='http://www.rubyonrails.org'
license=(MIT)
-depends=(ruby ruby-activesupport ruby-actionpack ruby-actionview ruby-activemodel ruby-activerecord ruby-actionmailer ruby-railties ruby-bundler ruby-sprockets-rails)
+depends=(ruby ruby-activesupport ruby-actionpack ruby-actionview ruby-activemodel \
+ ruby-activerecord ruby-actionmailer ruby-railties ruby-bundler ruby-sprockets-rails)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
@@ -19,6 +20,8 @@ sha1sums=('95b0fa311e719893165ae33c8378580b6da5e485')
package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
- gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ # No documentatoin due to https://github.com/rdoc/rdoc/issues/361
+ gem install --no-ri -no-rdoc --ignore-dependencies --no-user-install \
+ -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
}