summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimone Scalabrino2018-01-07 17:25:20 +0100
committerSimone Scalabrino2018-01-07 17:25:20 +0100
commit5e5511e0d02fc75536a3abd70731caf4206acb5a (patch)
tree2991216fdadb5b954472d331265f14c73830a8cd
downloadaur-5e5511e0d02fc75536a3abd70731caf4206acb5a.tar.gz
Version 1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26e842ef4349
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-remotesync-1.0.0
+ pkgdesc = Sync remote folders using ssh
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/intersimone999/remotesync
+ arch = any
+ license = GPL-3.0
+ depends = ruby
+ depends = ruby-colorize
+ noextract = remotesync-1.0.0.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/remotesync-1.0.0.gem
+ sha1sums = 2d33a20bec6fe8d37aee19f6dcee2a8d578c91d6
+
+pkgname = ruby-remotesync-1.0.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8600293c68f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Simone Scalabrino <s.scalabrino9@gmail.com>
+
+_gemname=remotesync
+pkgname=ruby-$_gemname-1.0.0
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Sync remote folders using ssh'
+arch=(any)
+url='https://github.com/intersimone999/remotesync'
+license=(GPL-3.0)
+depends=(ruby ruby-colorize)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('2d33a20bec6fe8d37aee19f6dcee2a8d578c91d6')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ # non-HEAD version should not install any files in /usr/bin
+ rm -r "$pkgdir/usr/bin/"
+}