summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStick2022-03-10 13:44:20 -0500
committerStick2022-03-10 13:44:20 -0500
commit222dbc31c26d89d59eb233dcdc18be9b6a486a4d (patch)
treed292ea2c658304cf1eabca7f30501c5250a2c4f6
downloadaur-222dbc31c26d89d59eb233dcdc18be9b6a486a4d.tar.gz
build package
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore78
-rw-r--r--PKGBUILD31
3 files changed, 126 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3780b70284a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ruby-rex-arch
+ pkgdesc = This library contains architecture specific information such as registers, opcodes, and stack manipulation routines.
+ pkgver = 0.1.14
+ pkgrel = 1
+ url = https://github.com/rapid7/rex-arch
+ arch = any
+ license = BSD
+ depends = ruby
+ depends = ruby-rex-text
+ noextract = rex-arch-0.1.14.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/rex-arch-0.1.14.gem
+ source = https://raw.githubusercontent.com/rapid7/rex-arch/master/LICENSE
+ sha256sums = 77111f85811731c3f95d571355356e9bba84bec843ad232318ef2683023129be
+ sha256sums = 22a0624299df52a759730e5e3c56bee73812e1760b4cd4382c29346058df4297
+
+pkgname = ruby-rex-arch
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..52b4ad87f839
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,78 @@
+LICENSE
+
+# Created by https://www.toptal.com/developers/gitignore/api/ruby,archlinuxpackages
+# Edit at https://www.toptal.com/developers/gitignore?templates=ruby,archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+### Ruby ###
+*.gem
+*.rbc
+/.config
+/coverage/
+/InstalledFiles
+/pkg/
+/spec/reports/
+/spec/examples.txt
+/test/tmp/
+/test/version_tmp/
+/tmp/
+
+# Used by dotenv library to load environment variables.
+# .env
+
+# Ignore Byebug command history file.
+.byebug_history
+
+## Specific to RubyMotion:
+.dat*
+.repl_history
+build/
+*.bridgesupport
+build-iPhoneOS/
+build-iPhoneSimulator/
+
+## Specific to RubyMotion (use of CocoaPods):
+#
+# We recommend against adding the Pods directory to your .gitignore. However
+# you should judge for yourself, the pros and cons are mentioned at:
+# https://guides.cocoapods.org/using/using-cocoapods.html#should-i-check-the-pods-directory-into-source-control
+# vendor/Pods/
+
+## Documentation cache and generated files:
+/.yardoc/
+/_yardoc/
+/doc/
+/rdoc/
+
+## Environment normalization:
+/.bundle/
+/vendor/bundle
+/lib/bundler/man/
+
+# for a library or gem, you might want to ignore these files since the code is
+# intended to run in multiple environments; otherwise, check them in:
+# Gemfile.lock
+# .ruby-version
+# .ruby-gemset
+
+# unless supporting rvm < 1.11.0 or doing something fancy, ignore this:
+.rvmrc
+
+# Used by RuboCop. Remote config files pulled in from inherit_from directive.
+# .rubocop-https?--*
+
+# End of https://www.toptal.com/developers/gitignore/api/ruby,archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..365b7d9e978e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Stick <stick@stma.is>
+
+_gemname=rex-arch
+pkgname=ruby-$_gemname
+pkgver=0.1.14
+pkgrel=1
+pkgdesc="This library contains architecture specific information such as registers, opcodes, and stack manipulation routines."
+arch=(any)
+url="https://github.com/rapid7/rex-arch"
+license=('BSD')
+depends=(
+ ruby
+ ruby-rex-text
+)
+options=(!emptydirs)
+source=(
+ https://rubygems.org/downloads/$_gemname-$pkgver.gem
+ https://raw.githubusercontent.com/rapid7/$_gemname/master/LICENSE
+)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=(
+ '77111f85811731c3f95d571355356e9bba84bec843ad232318ef2683023129be'
+ '22a0624299df52a759730e5e3c56bee73812e1760b4cd4382c29346058df4297'
+)
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -Dm644 "$srcdir"/LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}