summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2021-08-18 21:56:55 -0400
committerMario Finelli2021-08-18 21:56:55 -0400
commit3f6aa6dbe267ee5d65893b498d7fe4e1980f4f4e (patch)
tree5b5cdca9fb6599fb80085aa53205e4240098fb4b
parent37d779a13b977582f8dd7a45a3eecd3f1f3997aa (diff)
downloadaur-3f6aa6dbe267ee5d65893b498d7fe4e1980f4f4e.tar.gz
upgpkg: ruby-rubocop 1.19.0-2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
2 files changed, 54 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d57c82d2345a..a7b8025e1964 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,21 @@
pkgbase = ruby-rubocop
pkgdesc = A Ruby static code analyzer and formatter
pkgver = 1.19.0
- pkgrel = 1
+ pkgrel = 2
url = https://rubocop.org
arch = any
license = MIT
+ checkdepends = ruby-bundler
+ checkdepends = ruby-rake
+ checkdepends = ruby-rspec
+ checkdepends = ruby-webmock
+ checkdepends = ruby-rubocop-rspec
+ checkdepends = ruby-rubocop-performance
+ checkdepends = ruby-rubocop-rake
+ checkdepends = ruby-test-queue
+ checkdepends = ruby-yard
+ checkdepends = ruby-bump
+ checkdepends = ruby-rubocop-rails
makedepends = rubygems
makedepends = ruby-rdoc
depends = ruby
@@ -18,6 +29,8 @@ pkgbase = ruby-rubocop
depends = ruby-unicode-display_width
options = !emptydirs
source = https://github.com/rubocop/rubocop/archive/v1.19.0/rubocop-1.19.0.tar.gz
+ source = https://github.com/rubocop/rubocop/commit/4a5261591abe7d2f09a02add0b4e825291f35ae7.patch
sha256sums = c736a97e6793393844660309c9755e4824da8af0d67c4b7c8c5e1a56e46df70e
+ sha256sums = 9f00206230ce01b2a428f8090fea054dcefbe213902e34f0868a7da147887c78
pkgname = ruby-rubocop
diff --git a/PKGBUILD b/PKGBUILD
index c4dc804c56f4..e114457143aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_gemname=rubocop
pkgname=ruby-${_gemname}
pkgver=1.19.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Ruby static code analyzer and formatter"
arch=(any)
depends=(
@@ -18,16 +18,47 @@ depends=(
ruby-ruby-progressbar
ruby-unicode-display_width
)
+checkdepends=(
+ ruby-bundler
+ ruby-rake
+ ruby-rspec
+ ruby-webmock
+ ruby-rubocop-rspec
+ ruby-rubocop-performance
+ ruby-rubocop-rake
+ ruby-test-queue
+ ruby-yard
+ ruby-bump
+ ruby-rubocop-rails
+)
makedepends=(rubygems ruby-rdoc)
url=https://rubocop.org
license=(MIT)
options=(!emptydirs)
-source=(https://github.com/rubocop/rubocop/archive/v$pkgver/$_gemname-$pkgver.tar.gz)
-sha256sums=('c736a97e6793393844660309c9755e4824da8af0d67c4b7c8c5e1a56e46df70e')
+source=(https://github.com/rubocop/rubocop/archive/v$pkgver/$_gemname-$pkgver.tar.gz
+ https://github.com/rubocop/rubocop/commit/4a5261591abe7d2f09a02add0b4e825291f35ae7.patch)
+sha256sums=('c736a97e6793393844660309c9755e4824da8af0d67c4b7c8c5e1a56e46df70e'
+ '9f00206230ce01b2a428f8090fea054dcefbe213902e34f0868a7da147887c78')
prepare() {
cd $_gemname-$pkgver
+
+ # https://github.com/rubocop/rubocop/pull/10022
+ patch -p1 -N -i "$srcdir/4a5261591abe7d2f09a02add0b4e825291f35ae7.patch"
+
sed -i 's|~>|>=|g' ${_gemname}.gemspec
+
+ sed -i '/memory_profiler/d' Gemfile
+ sed -i '/simplecov/d' Gemfile
+ sed -i '/stackprof/d' Gemfile
+ sed -i 's|~>|>=|g' Gemfile
+
+ sed -i '/group/d' Gemfile
+ sed -i '/end/d' Gemfile
+
+ # rubocop-rspec on the aur is _old_
+ sed -i '/rubocop-rspec/d' Gemfile
+ echo "gem 'rubocop-rspec'" >> Gemfile
}
build() {
@@ -35,6 +66,12 @@ build() {
gem build ${_gemname}.gemspec
}
+check() {
+ cd $_gemname-$pkgver
+ rake spec
+ rake ascii_spec
+}
+
package() {
cd $_gemname-$pkgver
local _gemdir="$(gem env gemdir)"