summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2021-10-23 11:18:49 -0400
committerMario Finelli2021-10-23 11:18:49 -0400
commite5640249a2bde9bbf8d7a9432045bdea9b728b14 (patch)
tree39f180692c49a3993ad9ec501389c64614692383
parenta88dde16bad2f38b629ab109ff93db960dae76d0 (diff)
downloadaur-e5640249a2bde9bbf8d7a9432045bdea9b728b14.tar.gz
upgpkg: ruby-rubocop 1.22.2-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9132b13ff313..d5aade65de8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ruby-rubocop
pkgdesc = A Ruby static code analyzer and formatter
- pkgver = 1.22.1
+ pkgver = 1.22.2
pkgrel = 1
url = https://rubocop.org
arch = any
@@ -28,7 +28,9 @@ pkgbase = ruby-rubocop
depends = ruby-ruby-progressbar
depends = ruby-unicode-display_width
options = !emptydirs
- source = https://github.com/rubocop/rubocop/archive/v1.22.1/rubocop-1.22.1.tar.gz
- sha256sums = 711e6a8fb994a89ccc55afc791a0479c2394102b654d73cdc14b79066cd8a524
+ source = https://github.com/rubocop/rubocop/archive/v1.22.2/rubocop-1.22.2.tar.gz
+ source = https://github.com/rubocop/rubocop/commit/f5981241c80eee3a9dac81d497c9b5f226dafd20.patch
+ sha256sums = 3e3ed4f39c71d49a138d6783054fa4f8ea44425b746e64fa23d34c7999b4c69e
+ sha256sums = 37c50948329947d2460c09b43f8b35a73a99d646d6ef464754c1de550b68eb7a
pkgname = ruby-rubocop
diff --git a/PKGBUILD b/PKGBUILD
index 11153e10ce75..d2fd672f85e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_gemname=rubocop
pkgname=ruby-${_gemname}
-pkgver=1.22.1
+pkgver=1.22.2
pkgrel=1
pkgdesc="A Ruby static code analyzer and formatter"
arch=(any)
@@ -35,12 +35,17 @@ makedepends=(rubygems ruby-rdoc)
url=https://rubocop.org
license=(MIT)
options=(!emptydirs)
-source=(https://github.com/rubocop/rubocop/archive/v$pkgver/$_gemname-$pkgver.tar.gz)
-sha256sums=('711e6a8fb994a89ccc55afc791a0479c2394102b654d73cdc14b79066cd8a524')
+source=(https://github.com/rubocop/rubocop/archive/v$pkgver/$_gemname-$pkgver.tar.gz
+ https://github.com/rubocop/rubocop/commit/f5981241c80eee3a9dac81d497c9b5f226dafd20.patch)
+sha256sums=('3e3ed4f39c71d49a138d6783054fa4f8ea44425b746e64fa23d34c7999b4c69e'
+ '37c50948329947d2460c09b43f8b35a73a99d646d6ef464754c1de550b68eb7a')
prepare() {
cd $_gemname-$pkgver
+ # fix a broken test about the changelog
+ patch -p1 -N -i "$srcdir/f5981241c80eee3a9dac81d497c9b5f226dafd20.patch"
+
sed -i 's|~>|>=|g' ${_gemname}.gemspec
sed -i '/memory_profiler/d' Gemfile