diff options
author | Jeremy Audet | 2018-02-04 11:29:19 -0500 |
---|---|---|
committer | Jeremy Audet | 2018-02-04 11:29:19 -0500 |
commit | 11631a96d2f01298c8822a3e1605239f65bd8c77 (patch) | |
tree | 65fce219ea52df484c5ed3b1fb5e467af1ee5c99 | |
parent | bc93c6c137c8286b7872f2a637f6e742ea927676 (diff) | |
download | aur-11631a96d2f01298c8822a3e1605239f65bd8c77.tar.gz |
Drop -rubygems flag, add --no-document flag
Do the following:
* Drop `-rubygems` from `ruby -rubygems -e 'pus Gem.default_dir'`. This
flag appears to no longer be supported.
* Drop `makedepends=(rubygems)`. This dependency now resolves to the
"ruby" package, and the error above suggests that rubygems is no
longer a separate package.
* Add `--no-document` to `gem install ...`. This fixes a `cannot load
such file -- rdoc/rdoc` error. It's also the approach taken by the
ruby-hpricot community package.
-rw-r--r-- | .SRCINFO | 5 | ||||
-rw-r--r-- | PKGBUILD | 6 |
2 files changed, 4 insertions, 7 deletions
@@ -1,13 +1,10 @@ -# Generated by mksrcinfo v8 -# Tue Jul 18 20:43:53 UTC 2017 pkgbase = ruby-sexp_processor pkgdesc = A branch of ParseTree that brings several sexp processing tools. pkgver = 4.10.0 - pkgrel = 1 + pkgrel = 2 url = https://github.com/seattlerb/sexp_processor arch = any license = MIT - makedepends = rubygems depends = ruby noextract = sexp_processor-4.10.0.gem options = !emptydirs @@ -4,24 +4,24 @@ _gemname=sexp_processor pkgname="ruby-${_gemname}" pkgver=4.10.0 -pkgrel=1 +pkgrel=2 pkgdesc="A branch of ParseTree that brings several sexp processing tools." arch=(any) url="https://github.com/seattlerb/sexp_processor" license=(MIT) depends=(ruby) -makedepends=(rubygems) options=(!emptydirs) source=("http://gems.rubyforge.org/gems/${_gemname}-${pkgver}.gem") noextract=("${_gemname}-${pkgver}.gem") sha256sums=('b67a289ae4a3968d93dab0803d0ef5a262b6f94138ab98072e489d2aa8af4034') package() { - local _gemdir="$(ruby -rubygems -e 'puts Gem.default_dir')" + local _gemdir="$(ruby -e 'puts Gem.default_dir')" # install gem HOME=/tmp gem install \ --no-user-install \ + --no-document \ --ignore-dependencies \ --install-dir "${pkgdir}${_gemdir}" \ --bindir "${pkgdir}/usr/bin" \ |