summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Wörner2018-06-08 15:50:03 +0200
committerSimon Wörner2018-06-08 15:50:03 +0200
commitedaf8bdb88e56dc20c25174761f05f4f15e92ea3 (patch)
tree33c7d0e8a42d5c8354bf61a2fc1bb758261182b2
downloadaur-ruby-simple-navigation.tar.gz
init commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97ceac8b4d8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-simple-navigation
+ pkgdesc = simple-navigation is a ruby library for creating navigations (with multiple levels) for your Rails, Sinatra or Padrino application.
+ pkgver = 4.0.5
+ pkgrel = 1
+ url = http://github.com/codeplant/simple-navigation
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-activesupport
+ noextract = simple-navigation-4.0.5.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/simple-navigation-4.0.5.gem
+ sha1sums = 07f001c92f6252b991738890ba6765a8a7cc51a9
+
+pkgname = ruby-simple-navigation
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..390319720bf2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Simon Wörner <arch-pkg@simon-woerner.de>
+
+_gemname=simple-navigation
+pkgname=ruby-$_gemname
+pkgver=4.0.5
+pkgrel=1
+pkgdesc='simple-navigation is a ruby library for creating navigations (with multiple levels) for your Rails, Sinatra or Padrino application.'
+arch=(any)
+url='http://github.com/codeplant/simple-navigation'
+license=(MIT)
+depends=(ruby ruby-activesupport)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('07f001c92f6252b991738890ba6765a8a7cc51a9')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}