summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2015-08-22 21:28:55 -0700
committermutantmonkey2015-08-22 21:28:55 -0700
commitcde002b32167566652e41e022571d7eaab2d5f80 (patch)
tree5f9ca116609b73336d7a517e8f0941d29ae88a7f
parent7aca30800e04ea611bd1f1280e4e67049e51bef8 (diff)
downloadaur-cde002b32167566652e41e022571d7eaab2d5f80.tar.gz
upgpkg: ruby-slop 4.2.0-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29dc5dd96b49..20a17a839691 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = ruby-slop
pkgdesc = Simple Lightweight Option Parsing
- pkgver = 4.1.0
+ pkgver = 4.2.0
pkgrel = 1
- url = http://github.com/leejarvis/slop
+ url = https://github.com/leejarvis/slop
arch = any
license = MIT
depends = ruby
- noextract = slop-4.1.0.gem
+ noextract = slop-4.2.0.gem
options = !emptydirs
- source = https://rubygems.org/downloads/slop-4.1.0.gem
- sha512sums = 5d894afcfba7313ecee0f429089a0584a55ce14d4e969f8f5ae8dde0db7653829c453b55f66bc2a6570499c0ff24b94401f95d2af6b65e1eb1eb012ff3036f40
+ source = https://rubygems.org/downloads/slop-4.2.0.gem
+ sha256sums = 6cadcc224a8ad249755904ec6e591e867dcd2a695f50a4571bb5744e29bf24cc
pkgname = ruby-slop
diff --git a/PKGBUILD b/PKGBUILD
index b903dab62491..6454e6db434f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
+# Maintainer: mutantmonkey <aur@mutantmonkey.in>
# Generated by gem2arch (https://github.com/anatol/gem2arch)
-# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+# Contributor: Artem Vorotnikov <artem@vorotnikov.me>
_gemname=slop
pkgname=ruby-$_gemname
-pkgver=4.1.0
+pkgver=4.2.0
pkgrel=1
pkgdesc='Simple Lightweight Option Parsing'
arch=(any)
-url='http://github.com/leejarvis/slop'
+url='https://github.com/leejarvis/slop'
license=(MIT)
depends=(ruby)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
-sha512sums=('5d894afcfba7313ecee0f429089a0584a55ce14d4e969f8f5ae8dde0db7653829c453b55f66bc2a6570499c0ff24b94401f95d2af6b65e1eb1eb012ff3036f40')
+sha256sums=('6cadcc224a8ad249755904ec6e591e867dcd2a695f50a4571bb5744e29bf24cc')
package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
@@ -21,3 +22,5 @@ package() {
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+# vim:set ts=2 sw=2 et: