summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatěj Grabovský2015-06-09 16:57:18 +0200
committerMatěj Grabovský2015-06-09 16:57:18 +0200
commitefcb5bf65d70f7e71f4a9d7a276388ab2c475be8 (patch)
tree9be864ab4d1522519b7ffe54901b9e67f58fec08
downloadaur-efcb5bf65d70f7e71f4a9d7a276388ab2c475be8.tar.gz
Initial import from old AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d25642a68330
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ruby-sprockets-rails
+ pkgdesc = Sprockets Rails integration
+ pkgver = 2.2.4
+ pkgrel = 1
+ url = https://github.com/rails/sprockets-rails
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-sprockets
+ depends = ruby-actionpack
+ depends = ruby-activesupport
+ noextract = sprockets-rails-2.2.4.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/sprockets-rails-2.2.4.gem
+ sha1sums = d3e1f38574808e8bb1125e49c19d43a97fb92ab6
+
+pkgname = ruby-sprockets-rails
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07efc84c122c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Matej Grabovsky <matej.grabovsky at gmail>
+# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
+# Contributor: Nathan Phillip Brink <binki@gentoo.org>
+
+_gemname=sprockets-rails
+pkgname=ruby-$_gemname
+pkgver=2.2.4
+pkgrel=1
+pkgdesc='Sprockets Rails integration'
+arch=(any)
+url='https://github.com/rails/sprockets-rails'
+license=(MIT)
+depends=(ruby ruby-sprockets ruby-actionpack ruby-activesupport)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('d3e1f38574808e8bb1125e49c19d43a97fb92ab6')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}