summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadioLogic2024-04-27 13:41:07 -0400
committerRadioLogic2024-04-27 13:41:07 -0400
commiteaecef35acda2ddf93dfa9f596a04509c620f638 (patch)
tree6d1e0243c0e13be0d56cc0ae4bc7fe0ec4d13ceb
downloadaur-eaecef35acda2ddf93dfa9f596a04509c620f638.tar.gz
Inital commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c901df1bdd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ruby-subprocess
+ pkgdesc = Control and communicate with spawned processes
+ pkgver = 1.5.6
+ pkgrel = 1
+ url = http://solargraph.org/
+ arch = any
+ license = MIT
+ makedepends = rubygems
+ depends = ruby>=2.7.0
+ depends = ruby-minitest>=5.0
+ depends = ruby-pry
+ depends = ruby-rake
+ depends = ruby-sord
+ noextract = subprocess-1.5.6.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/subprocess-1.5.6.gem
+ sha256sums = 420bc80395fd7695852b1f3d13188c5bbc63061d0a512dc8c3e5acd41d54896c
+
+pkgname = ruby-subprocess
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a628ee1a1cfb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: mnussbaum <michaelnussbaum08@gmail.com>
+
+pkgname=ruby-subprocess
+_gemname=${pkgname#ruby-}
+pkgver=1.5.6
+pkgrel=1
+pkgdesc="Control and communicate with spawned processes"
+arch=("any")
+depends=(
+ 'ruby>=2.7.0'
+ 'ruby-minitest>=5.0'
+ 'ruby-pry'
+ 'ruby-rake'
+ 'ruby-sord'
+)
+makedepends=(rubygems)
+url="http://solargraph.org/"
+noextract=($_gemname-$pkgver.gem)
+license=("MIT")
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+sha256sums=('420bc80395fd7695852b1f3d13188c5bbc63061d0a512dc8c3e5acd41d54896c')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+
+ gem install \
+ --ignore-dependencies \
+ --no-user-install \
+ -i "$pkgdir/$_gemdir" \
+ -n "$pkgdir/usr/bin" \
+ $_gemname-$pkgver.gem
+
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+}