summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHusam Bilal2017-04-06 14:26:08 +0300
committerHusam Bilal2017-04-06 14:26:08 +0300
commit4548c74ac805279a63c97323430ac2935ec614cb (patch)
treecf4ab32c149f0598c565ce557ef867386ea94b86
downloadaur-4548c74ac805279a63c97323430ac2935ec614cb.tar.gz
initial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e34094cb59e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ruby-test-unit
+ pkgdesc = Unit testing framework for Ruby, based on xUnit principles.
+ pkgver = 3.2.3
+ pkgrel = 1
+ url = http://test-unit.github.io
+ arch = any
+ license = GPL
+ makedepends = rubygems
+ depends = ruby
+ noextract = test-unit-3.2.3.gem
+ source = https://rubygems.org/downloads/test-unit-3.2.3.gem
+ sha256sums = fe125f1418b223b9d84ea12c2557d87ccc98d2c4ae5b7ef63c75611dc4edcfce
+
+pkgname = ruby-test-unit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f2aeaf35314
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Husam Bilal <husam212@gmail.com>
+
+_gemname=test-unit
+pkgname=ruby-$_gemname
+pkgver=3.2.3
+pkgrel=1
+pkgdesc='Unit testing framework for Ruby, based on xUnit principles.'
+arch=(any)
+url='http://test-unit.github.io'
+license=(GPL)
+depends=(ruby)
+makedepends=(rubygems)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('fe125f1418b223b9d84ea12c2557d87ccc98d2c4ae5b7ef63c75611dc4edcfce')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/COPYING" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+