summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-01-30 16:07:29 +0300
committerViktor Drobot2020-01-30 16:07:29 +0300
commit1193d0aea0c54c8682f6cd4ff388decf21bb0851 (patch)
tree19e5eb990121af47405b52dc3de46f3de6715bb7
downloadaur-1193d0aea0c54c8682f6cd4ff388decf21bb0851.tar.gz
Initial release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45898cf498d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ruby-test-unit-rr-bootstrap
+ pkgdesc = RR adapter for test-unit (bootstrap version)
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://github.com/test-unit/test-unit-rr
+ arch = any
+ license = LGPL2.1
+ depends = ruby
+ depends = ruby-rr
+ provides = ruby-test-unit-rr
+ conflicts = ruby-test-unit-rr
+ options = !emptydirs
+ source = https://rubygems.org/downloads/test-unit-rr-1.0.5.gem
+ md5sums = d2919c305ae5355080afc39904d30a62
+
+pkgname = ruby-test-unit-rr-bootstrap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ab9d35096ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+_gemname="test-unit-rr"
+pkgname="ruby-${_gemname}-bootstrap"
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="RR adapter for test-unit (bootstrap version)"
+arch=(any)
+url="https://github.com/test-unit/test-unit-rr"
+license=("LGPL2.1")
+depends=("ruby" "ruby-rr")
+conflicts=("ruby-${_gemname}")
+provides=("ruby-${_gemname}")
+options=(!emptydirs)
+source=("https://rubygems.org/downloads/${_gemname}-${pkgver}.gem")
+md5sums=('d2919c305ae5355080afc39904d30a62')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+
+ gem install --ignore-dependencies --no-user-install --no-document -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+}