summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoop Kiefte2018-12-19 01:55:18 +0100
committerJoop Kiefte2018-12-19 01:55:18 +0100
commit2f35cd8864bef81c3cf0711c01eb3d163d1335fd (patch)
treec54343955bf4566e3be6ff9716e4f9bfbc8c1375
downloadaur-2f35cd8864bef81c3cf0711c01eb3d163d1335fd.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..607af198ea70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-textplay-git
+ pkgdesc = Convert fountain screenplays to Final Draft and HTML format, and convert HTML to PDF.
+ pkgver = r87.88f7871
+ pkgrel = 1
+ url = https://www.olivertaylor.net/
+ arch = any
+ license = custom:textplay
+ makedepends = git
+ depends = ruby
+ provides = ruby-textplay
+ conflicts = ruby-textplay
+ source = ruby-textplay::git+https://github.com/olivertaylor/Textplay
+ md5sums = SKIP
+
+pkgname = ruby-textplay-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f60660c06d58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Joop Kiefte <joop@kiefte.net>
+pkgname=ruby-textplay-git
+pkgver=r87.88f7871
+pkgrel=1
+pkgdesc="Convert fountain screenplays to Final Draft and HTML format, and convert HTML to PDF."
+arch=('any')
+url="https://www.olivertaylor.net/"
+license=('custom:textplay')
+depends=('ruby')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=
+source=('ruby-textplay::git+https://github.com/olivertaylor/Textplay')
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
+ install -Dm755 textplay "$pkgdir/usr/bin/textplay"
+}