summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2013-09-27 08:26:06 +0000
committerMaxime Gauduin2013-09-27 08:26:06 +0000
commit0dc11e134b16565e4b9d4681a8d3ac297390f66b (patch)
tree22aa30b174cfdd36a5ea7830cf2c87d0c4dfa559
downloadaur-0dc11e134b16565e4b9d4681a8d3ac297390f66b.tar.gz
Add taskjuggler3 and its dependencies
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..284027649ff5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Maxime Gauduin <alucryd@gmail@com>
+# Contributor: Emiliano Vavassori <syntaxerrormmm@gmail.com>
+# Contributor: Guilherme Nogueira <guilherme@nirev.org>
+
+pkgname=ruby-treetop
+pkgver=1.4.15
+pkgrel=2
+pkgdesc="A Ruby-based text parsing and interpretation DSL"
+arch=('any')
+url="http://functionalform.blogspot.com/"
+license=('MIT')
+depends=('ruby-polyglot')
+source=("http://rubygems.org/downloads/${pkgname#*-}-${pkgver}.gem")
+noextract=("${pkgname#*-}-$pkgver.gem")
+sha256sums=('ffa68f201c0f62c26b0a1d13233d73194400596964696843f87ebb5d812f12ff')
+
+prepare() {
+ gem install --no-{document,user-install} --ignore-dependencies -i . ${pkgname#*-}-${pkgver}.gem
+}
+
+package() {
+ cd gems/${pkgname#*-}-${pkgver}
+
+ local _rubyver="$(ruby --version | sed 's/.* \(.*\..*\..*\)p.*/\1/')"
+
+ install -dm 755 "${pkgdir}"/usr/lib/ruby/{gems/${_rubyver},vendor_ruby}
+ mv bin "${pkgdir}"/usr/
+ mv lib "${pkgdir}"/usr/lib/ruby/vendor_ruby/${_rubyver}
+
+# Gem compatibility
+ mv ../../specifications "${pkgdir}"/usr/lib/ruby/gems/${_rubyver}/
+
+# License
+ install -dm 755 "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -m 644 {,"${pkgdir}"/usr/share/licenses/${pkgname}/}LICENSE
+}
+
+# vim: ts=2 sw=2 et: