summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2017-05-12 21:21:51 -0400
committerJames An2017-05-12 21:21:51 -0400
commit19cbe3405ee1327b68f5fe8a56c7547f1dc9f0f1 (patch)
tree2b27548d544dc1d0a63619fec14aae0e8be7cca3
parente9401f63bf584c0e6ae808257579727384f5ce2a (diff)
downloadaur-ruby-tuple.tar.gz
Fixed support for Ruby 2.4.x.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--ruby-2.x.patch (renamed from ruby-2.3.x.patch)4
3 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fcb6dbae7da..7cc89540d8e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ruby-tuple
pkgdesc = Tuple serialization functions.
pkgver = 0.1.2
- pkgrel = 2
+ pkgrel = 3
url = http://github.com/topac/tuple
arch = i686
arch = x86_64
@@ -9,9 +9,9 @@ pkgbase = ruby-tuple
depends = ruby
options = !emptydirs
source = tuple::git+https://github.com/topac/tuple.git
- source = ruby-2.3.x.patch
+ source = ruby-2.x.patch
md5sums = SKIP
- md5sums = 02ccd33d02bedc16612ef5be9aec4c44
+ md5sums = 136ab235fc7b6513b86f48a35953dcab
pkgname = ruby-tuple
diff --git a/PKGBUILD b/PKGBUILD
index 60c89d510c81..88c65c97e3f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=tuple
pkgname=ruby-$_pkgname
pkgver=0.1.2
-pkgrel=2
+pkgrel=3
pkgdesc='Tuple serialization functions.'
arch=(i686 x86_64)
url="http://github.com/topac/$_pkgname"
@@ -12,14 +12,14 @@ license=(MIT)
depends=(ruby)
options=(!emptydirs)
source=("$_pkgname"::"git+https://github.com/topac/$_pkgname.git"
- ruby-2.3.x.patch)
+ ruby-2.x.patch)
md5sums=('SKIP'
- '02ccd33d02bedc16612ef5be9aec4c44')
+ '136ab235fc7b6513b86f48a35953dcab')
prepare() {
cd "$_pkgname"
- patch -p1 -i ../ruby-2.3.x.patch
+ patch -p1 -i ../ruby-2.x.patch
}
build () {
diff --git a/ruby-2.3.x.patch b/ruby-2.x.patch
index fde38dbc40bb..a9083ec379d8 100644
--- a/ruby-2.3.x.patch
+++ b/ruby-2.x.patch
@@ -1,4 +1,4 @@
-diff --git a/ext/tuple/extconf.rb b/ext/tuple/extconf.rb
+ diff --git a/ext/tuple/extconf.rb b/ext/tuple/extconf.rb
index ce4e688..3b2b1ac 100644
--- a/ext/tuple/extconf.rb
+++ b/ext/tuple/extconf.rb
@@ -7,7 +7,7 @@ index ce4e688..3b2b1ac 100644
$CFLAGS += ' -DRUBY_2_x_x'
$CFLAGS += ' -DRUBY_2_1_x'
-when /\A2\.2/
-+when /\A2\.2/, /\A2\.3/
++when /\A2\.(2|3|4)/
$CFLAGS += ' -DRUBY_2_x_x'
$CFLAGS += ' -DRUBY_2_2_x'
else