summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-06-02 12:59:14 -0400
committerJames An2015-06-02 12:59:14 -0400
commiteb10790319ca5fd706172d123ea25f04fe2f7b12 (patch)
treeaadc9ce69f103ba3f579ba25fccdb459eeed1bce
downloadaur-eb10790319ca5fd706172d123ea25f04fe2f7b12.tar.gz
Added new AUR package, ruby-tuple.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8fcc130c39e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ruby-tuple
+ pkgdesc = Tuple serialization functions.
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = http://github.com/topac/tuple
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = ruby
+ options = !emptydirs
+ source = tuple::git+https://github.com/topac/tuple.git
+ md5sums = SKIP
+
+pkgname = ruby-tuple
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80734e901462
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: James An <james@jamesan.ca>
+
+_pkgname=tuple
+pkgname=ruby-$_pkgname
+pkgver=0.1.2
+pkgrel=1
+pkgdesc='Tuple serialization functions.'
+arch=(i686 x86_64)
+url="http://github.com/topac/$_pkgname"
+license=(MIT)
+depends=(ruby)
+options=(!emptydirs)
+source=("$_pkgname"::"git+https://github.com/topac/$_pkgname.git")
+md5sums=('SKIP')
+
+build () {
+ cd $_pkgname
+ gem build $_pkgname.gemspec
+}
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_pkgname/$_pkgname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_pkgname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}