summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Feuls2017-02-14 16:03:23 +0100
committerCarsten Feuls2017-02-14 16:03:23 +0100
commitf1e8305e424fd459bf19f179e1f051fabe119561 (patch)
treeae0575845f7d036f1f0e6182d15dcec2cd81dd22
downloadaur-f1e8305e424fd459bf19f179e1f051fabe119561.tar.gz
Initial Commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c27abe30f275
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Feb 14 15:03:13 UTC 2017
+pkgbase = ruby-typhoeus-0.6
+ pkgdesc = Parallel HTTP library on top of libcurl multi.
+ pkgver = 0.6.8
+ pkgrel = 1
+ url = https://github.com/typhoeus/typhoeus
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-ethon>=0.9.0
+ noextract = typhoeus-0.6.8.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/typhoeus-0.6.8.gem
+ sha512sums = 11d00c258aecfa1298c986703bec48112cbf40d3dbf8d6c1be8909fe90b8c162df3ac2e947874352e90afcca0fff805a426eb3941116d10c6aa85801691c2523
+
+pkgname = ruby-typhoeus-0.6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67e527306d1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+#Maintainer: Carsten Feuls <archlinux@carstenfeuls.de>
+
+_gemname=typhoeus
+pkgname=ruby-$_gemname-0.6
+pkgver=0.6.8
+pkgrel=1
+pkgdesc='Parallel HTTP library on top of libcurl multi.'
+arch=(any)
+url='https://github.com/typhoeus/typhoeus'
+license=(MIT)
+depends=('ruby' 'ruby-ethon>=0.9.0')
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+sha512sums=('11d00c258aecfa1298c986703bec48112cbf40d3dbf8d6c1be8909fe90b8c162df3ac2e947874352e90afcca0fff805a426eb3941116d10c6aa85801691c2523')