summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2020-09-29 05:43:07 +1300
committerGeorge Rawlinson2020-09-29 05:43:07 +1300
commit9a94b2ca5abf4e01dbd351adb1baac5442906041 (patch)
tree5f72410ab53917c101b36184b9d2dbdecc230ad9
downloadaur-9a94b2ca5abf4e01dbd351adb1baac5442906041.tar.gz
addpkg: ruby-tzinfo-data 1.2020.1-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b294bfca88da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-tzinfo-data
+ pkgdesc = Timezone data for ruby-tzinfo
+ pkgver = 1.2020.1
+ pkgrel = 1
+ url = https://github.com/tzinfo/tzinfo-data
+ arch = x86_64
+ license = MIT
+ depends = ruby
+ depends = ruby-tzinfo
+ noextract = tzinfo-data-1.2020.1.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/tzinfo-data-1.2020.1.gem
+ b2sums = 79abe079d811b3ee03e827cf19a4cfaa4d1be5fb07a9605ce393296858e9f6458659f70a8abbb718a4e24d31a89980677d4f8c268d2ddb30475656fc7fe26dae
+
+pkgname = ruby-tzinfo-data
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e5cff16a6ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: George Rawlinson <george@rawlinson.net.nz>
+
+_gemname=tzinfo-data
+pkgname=ruby-$_gemname
+pkgver=1.2020.1
+pkgrel=1
+pkgdesc='Timezone data for ruby-tzinfo'
+arch=(x86_64)
+url='https://github.com/tzinfo/tzinfo-data'
+license=(MIT)
+depends=(ruby ruby-tzinfo)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+b2sums=('79abe079d811b3ee03e827cf19a4cfaa4d1be5fb07a9605ce393296858e9f6458659f70a8abbb718a4e24d31a89980677d4f8c268d2ddb30475656fc7fe26dae')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install --no-document -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}