summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre ZANNI2024-01-23 14:05:21 +0100
committerAlexandre ZANNI2024-01-23 14:05:21 +0100
commit72a062ae3b8504fc047e37061c5649a0bf6824c9 (patch)
treef0e179b792f6c0673042cb4db78f2184f0179dd6
downloadaur-72a062ae3b8504fc047e37061c5649a0bf6824c9.tar.gz
ruby-unicode-confusable
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD26
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9842e4adfa36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ruby-unicode-confusable
+ pkgdesc = Unicode confusables helper in Ruby.
+ pkgver = 1.10.0
+ pkgrel = 1
+ url = https://github.com/janlelis/unicode-confusable
+ arch = any
+ license = MIT
+ depends = ruby
+ noextract = unicode-confusable-1.10.0.gem
+ source = https://rubygems.org/downloads/unicode-confusable-1.10.0.gem
+ sha512sums = d499c89464e3360e916d7273b53f8343592b9455b5f3290cbabe3b522d7164325b6e8d59c6c4e861701ae52398a6c111b54893d43ea8d950337ad3a728238790
+
+pkgname = ruby-unicode-confusable
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..86339a0c1972
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.gem \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c26df125d294
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: noraj <printf %s 'YWxleGFuZHJlLnphbm5pQGV1cm9wZS5jb20='|base64 -d>
+
+pkgname=ruby-unicode-confusable
+_gemname=${pkgname#ruby-}
+pkgver=1.10.0
+pkgrel=1
+pkgdesc='Unicode confusables helper in Ruby.'
+arch=('any')
+url='https://github.com/janlelis/unicode-confusable'
+license=('MIT')
+depends=('ruby')
+source=("https://rubygems.org/downloads/$_gemname-$pkgver.gem")
+noextract=("$_gemname-$pkgver.gem")
+sha512sums=('d499c89464e3360e916d7273b53f8343592b9455b5f3290cbabe3b522d7164325b6e8d59c6c4e861701ae52398a6c111b54893d43ea8d950337ad3a728238790')
+
+package() {
+ _gemhome="$(gem env home)"
+
+ gem install --ignore-dependencies --no-user-install --no-document \
+ -i "$pkgdir/$_gemhome" -n "$pkgdir/usr/bin" "$_gemname-$pkgver.gem"
+
+ rm "$pkgdir/$_gemhome/cache/$_gemname-$pkgver.gem"
+
+ install -Dm 644 "$pkgdir/$_gemhome/gems/$_gemname-$pkgver/MIT-LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}