summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfarwayer2020-04-04 11:41:18 +0300
committerfarwayer2020-04-04 11:41:18 +0300
commitc979ca1c51a13f9fd834733da2937e67bcdc4cf1 (patch)
tree21c75d3dc7ef84f52405c4cbef46d8f6d2114e6c
parent392798e339f09fd4bac4f04e59dfd8c416f6247c (diff)
downloadaur-c979ca1c51a13f9fd834733da2937e67bcdc4cf1.tar.gz
1.7.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a05212617dc..b161213bcdd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = ruby-unicode-display_width
- pkgdesc = [Unicode 12.1.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data.
- pkgver = 1.6.0
+ pkgdesc = [Unicode 13.0.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data.
+ pkgver = 1.7.0
pkgrel = 1
- url = https://rubygems.org/gems/unicode-display_width
+ url = https://rubygems.org/gems/${_gemname}
arch = any
license = MIT
- makedepends = ruby-rdoc
depends = ruby
- noextract = unicode-display_width-1.6.0.gem
- source = https://rubygems.org/downloads/unicode-display_width-1.6.0.gem
- sha256sums = 5cfcc08491f3978e8506b5527d9e871beeffe2b5dacc62df78fb86a9a28d6e22
+ noextract = unicode-display_width-1.7.0.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/unicode-display_width-1.7.0.gem
+ sha1sums = 6d743a99b24181c979b99f09df161fb2a2d983bf
pkgname = ruby-unicode-display_width
diff --git a/PKGBUILD b/PKGBUILD
index be0154301915..55bc1ec95b3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,17 @@
_gemname=unicode-display_width
pkgname=ruby-${_gemname}
-pkgver=1.6.0
+pkgver=1.7.0
pkgrel=1
-pkgdesc="[Unicode 12.1.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data."
-arch=('any')
-depends=('ruby')
-makedepends=('ruby-rdoc')
-url="https://rubygems.org/gems/${_gemname}"
+pkgdesc='[Unicode 13.0.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data.'
+arch=(any)
+depends=(ruby)
+url='https://rubygems.org/gems/${_gemname}'
noextract=($_gemname-$pkgver.gem)
-license=('MIT')
-source=(
- "https://rubygems.org/downloads/${_gemname}-${pkgver}.gem"
-)
-sha256sums=('5cfcc08491f3978e8506b5527d9e871beeffe2b5dacc62df78fb86a9a28d6e22')
+options=(!emptydirs)
+license=(MIT)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+sha1sums=('6d743a99b24181c979b99f09df161fb2a2d983bf')
package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"