summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonne Haß2017-05-15 21:24:19 +0200
committerJonne Haß2017-05-15 21:24:43 +0200
commite67dc71721c6201b0f6cdbe651822f0f9356fd60 (patch)
treeaaafb815b2a8ec27ac263c58c6b0c66501713667
parent84020614237a13deb720c09c91329df2df619a76 (diff)
downloadaur-e67dc71721c6201b0f6cdbe651822f0f9356fd60.tar.gz
ruby2.2: depend on openssl-1.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63d31741465f..24f63d943929 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ruby2.2
pkgdesc = An object-oriented language for quick and easy programming
pkgver = 2.2.7
- pkgrel = 1
+ pkgrel = 2
url = http://www.ruby-lang.org/en/
arch = i686
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = ruby2.2
makedepends = ttf-dejavu
makedepends = tk
depends = gdbm
- depends = openssl
+ depends = openssl-1.0
depends = libffi
depends = libyaml
depends = gmp
diff --git a/PKGBUILD b/PKGBUILD
index 202b846bbcee..00d9307bd799 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@
pkgname=ruby2.2
pkgver=2.2.7
pkgdesc='An object-oriented language for quick and easy programming'
-pkgrel=1
+pkgrel=2
arch=(i686 x86_64)
url='http://www.ruby-lang.org/en/'
license=(BSD custom)
-depends=(gdbm openssl libffi libyaml gmp zlib)
+depends=(gdbm openssl-1.0 libffi libyaml gmp zlib)
optdepends=('tk: for Ruby/TK')
makedepends=(gdbm openssl libffi doxygen graphviz libyaml ttf-dejavu tk)
options=(!emptydirs)
@@ -20,6 +20,7 @@ source=(https://cache.ruby-lang.org/pub/ruby/${pkgver:0:3}/ruby-${pkgver}.tar.xz
build() {
cd ruby-${pkgver}
+ export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
PKG_CONFIG=/usr/bin/pkg-config ./configure \
--prefix=/opt/ruby2.2 \
--program-suffix=-2.2 \