summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-13 12:15:52 +0200
committerGoliathLabs2020-05-13 12:15:52 +0200
commit54c7ec696673fec635cc0a69377c3e140d950e98 (patch)
tree458f6c4c53b584111920ae439acd34473d4cba9d
parent7a4e01f8f59504f5e3ea7305067a7c83bce78e55 (diff)
downloadaur-54c7ec696673fec635cc0a69377c3e140d950e98.tar.gz
Updated: 2.7.8
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
2 files changed, 47 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 155e4b64d8ea..a88ae64b16a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,7 @@
pkgbase = ruby2.5
- pkgdesc = An object-oriented language for quick and easy programming (version 2.5)
- pkgver = 2.5.7
+ pkgver = 2.5.8
pkgrel = 1
- url = http://www.ruby-lang.org/en/
+ url = https://www.ruby-lang.org/en/
arch = x86_64
license = BSD
license = custom
@@ -14,16 +13,23 @@ pkgbase = ruby2.5
makedepends = libyaml
makedepends = ttf-dejavu
makedepends = tk
+ options = !emptydirs
+ source = https://cache.ruby-lang.org/pub/ruby/2.5/ruby-2.5.8.tar.xz
+ sha512sums = 2886be764a454425c5beef2777c64a70ee0d048b07896b327633d904f5077fea4299526689f9e2ac4dcd2fc4811cf9a6c8ce75367ed35d29dfe1a54222872e0d
+
+pkgname = ruby2.5
+ pkgdesc = An object-oriented language for quick and easy programming
depends = gdbm
depends = openssl
depends = libffi
depends = libyaml
depends = gmp
depends = zlib
+ depends = rubygems
+ depends = ruby-irb
+ optdepends = ruby-docs: Ruby documentation
optdepends = tk: for Ruby/TK
- options = !emptydirs
- source = https://cache.ruby-lang.org/pub/ruby/2.5/ruby-2.5.7.tar.xz
- sha512sums = 63b7c75fab44cd1bd22f22ddec00c740cf379ac7240da0dfafcec54347766695faef47428ce1c433fd77fa96992e976c984697067fa526236d383b12adc9ce75
-pkgname = ruby2.5
+pkgname = ruby2.5-docs
+ pkgdesc = Documentation files for ruby
diff --git a/PKGBUILD b/PKGBUILD
index 0dbb22764ff3..8596aad99150 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer:
+# Maintainer: Felix Golatofski <contact@xdfr.de>
# Contributor: Sven-Hendrik Haase <svenstaro@gmail.com>
# Contributor: Thomas Dziedzic <gostrc@gmail.com>
# Contributor: Allan McRae <allan@archlinux.org>
@@ -6,19 +6,22 @@
# Contributor: Jeramy Rutley <jrutley@gmail.com>
_rubyver=2.5
-pkgname=ruby2.5
-pkgver=2.5.7
-pkgdesc='An object-oriented language for quick and easy programming (version 2.5)'
+pkgname=(ruby2.5 ruby2.5-docs)
+pkgver=2.5.8
pkgrel=1
arch=(x86_64)
-url='http://www.ruby-lang.org/en/'
+url='https://www.ruby-lang.org/en/'
license=(BSD custom)
-depends=(gdbm openssl libffi libyaml gmp zlib)
-optdepends=('tk: for Ruby/TK')
makedepends=(gdbm openssl libffi doxygen graphviz libyaml ttf-dejavu tk)
options=(!emptydirs)
source=(https://cache.ruby-lang.org/pub/ruby/${pkgver:0:3}/ruby-${pkgver}.tar.xz)
-sha512sums=('63b7c75fab44cd1bd22f22ddec00c740cf379ac7240da0dfafcec54347766695faef47428ce1c433fd77fa96992e976c984697067fa526236d383b12adc9ce75')
+sha512sums=('2886be764a454425c5beef2777c64a70ee0d048b07896b327633d904f5077fea4299526689f9e2ac4dcd2fc4811cf9a6c8ce75367ed35d29dfe1a54222872e0d')
+
+prepare() {
+ cd ruby-${pkgver}
+ # remove bundled gems, we are going to ship them as separate packages
+ rm -rf gems/
+}
build() {
cd ruby-${pkgver}
@@ -43,11 +46,22 @@ check() {
make test
}
-package() {
+package_ruby2.5() {
+ pkgdesc='An object-oriented language for quick and easy programming'
+ depends=(gdbm openssl libffi libyaml gmp zlib rubygems ruby-irb)
+ optdepends=(
+ 'ruby-docs: Ruby documentation'
+ 'tk: for Ruby/TK'
+ )
cd ruby-${pkgver}
make DESTDIR="${pkgdir}" install-nodoc
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/ruby/LICENSE"
+ install -D -m644 BSDL "${pkgdir}/usr/share/licenses/ruby/BSDL"
+
+ rubyver=${pkgver:0:3}.0
+
install -dm755 $pkgdir/usr/bin
install -dm755 $pkgdir/usr/lib
@@ -58,6 +72,15 @@ package() {
ln -s /opt/$pkgname/lib/libruby.so.${_rubyver} $pkgdir/usr/lib/libruby.so.${_rubyver}
- install -D -m644 COPYING "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
- install -D -m644 BSDL "${pkgdir}/usr/share/licenses/$pkgname/BSDL"
+}
+
+package_ruby2.5-docs() {
+ pkgdesc='Documentation files for ruby'
+
+ cd ruby-${pkgver}
+
+ make DESTDIR="${pkgdir}" install-doc install-capi
+
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/ruby-docs/LICENSE"
+ install -D -m644 BSDL "${pkgdir}/usr/share/licenses/ruby-docs/BSDL"
}