summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2021-01-28 19:18:16 -0500
committerMario Finelli2021-01-28 19:18:16 -0500
commit9e08daba79aa35e4af2e504bc67a0dec9e22af44 (patch)
tree9e918a00dc747e5550611703ad7f317618807409
parent84f587bf85255ed7ad49ca244e5f1036ed338c98 (diff)
downloadaur-9e08daba79aa35e4af2e504bc67a0dec9e22af44.tar.gz
Update to 2020.3.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD92
2 files changed, 53 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ab714f13382..b2864e9aed3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rubymine
- pkgdesc = Ruby and Rails IDE with the full stack of essential developer tools.
- pkgver = 2020.3.1
+ pkgdesc = Ruby and Rails IDE with the full stack of essential developer tools
+ pkgver = 2020.3.2
pkgrel = 1
url = https://www.jetbrains.com/ruby/
install = rubymine.install
@@ -11,10 +11,10 @@ pkgbase = rubymine
depends = gtk-update-icon-cache
optdepends = ruby: Ruby run/debug support
options = !strip
- source = https://download.jetbrains.com/ruby/RubyMine-2020.3.1.tar.gz
+ source = https://download.jetbrains.com/ruby/RubyMine-2020.3.2.tar.gz
source = rubymine.desktop
source = rubymine.install
- sha256sums = 8cd8a858f603f1d4f7adf0f99c374003e21475e516bdaf498eb03230cdff3d37
+ sha256sums = 6c3c63aa87d720f0be10aa54435b3d95899533ee2320f98ae857fc29c9d7a39f
sha256sums = 72df0e7c605caf7b6c98e9335f4eee9c8bfe8fcc24523634fd8c1ebe019534d6
sha256sums = 7ecadddf2b315b22df3a5c7b90e18be7ea69e2a0d869ee18bf0e031b2c508f76
diff --git a/PKGBUILD b/PKGBUILD
index 9bdb49caf1b9..b135a785841f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,67 +7,73 @@
pkgname=rubymine
_pkgname=RubyMine
-pkgver=2020.3.1
+pkgver=2020.3.2
pkgrel=1
-pkgdesc="Ruby and Rails IDE with the full stack of essential developer tools."
-arch=('i686' 'x86_64')
+pkgdesc="Ruby and Rails IDE with the full stack of essential developer tools"
+arch=(i686 x86_64)
options=(!strip)
-url="https://www.jetbrains.com/ruby/"
-license=('custom')
-depends=('desktop-file-utils' 'gtk-update-icon-cache')
+url=https://www.jetbrains.com/ruby/
+license=(custom)
+depends=(desktop-file-utils gtk-update-icon-cache)
optdepends=('ruby: Ruby run/debug support')
install=rubymine.install
source=(https://download.jetbrains.com/ruby/${_pkgname}-${pkgver}.tar.gz
rubymine.desktop
rubymine.install)
-sha256sums=('8cd8a858f603f1d4f7adf0f99c374003e21475e516bdaf498eb03230cdff3d37'
+sha256sums=('6c3c63aa87d720f0be10aa54435b3d95899533ee2320f98ae857fc29c9d7a39f'
'72df0e7c605caf7b6c98e9335f4eee9c8bfe8fcc24523634fd8c1ebe019534d6'
'7ecadddf2b315b22df3a5c7b90e18be7ea69e2a0d869ee18bf0e031b2c508f76')
prepare() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
- #Remove non-linux libs
- rm -rf "lib/libpty/macosx"
- rm -rf "lib/libpty/win"
+ # Remove non-linux libs
+ rm -rf lib/libpty/macosx
+ rm -rf lib/libpty/win
- #Remove bin/libs if architecture doesn't match
- if [[ $CARCH = 'i686' ]]; then
- rm -f "bin/fsnotifier64"
- rm -f "bin/libbreakgen64.so"
- rm -f "bin/libyjpagent-linux64.so"
- rm -f "bin/rubymine64.vmoptions"
- rm -rf "lib/libpty/linux/x86_64"
- fi
- if [[ $CARCH = 'x86_64' ]]; then
- rm -f "bin/fsnotifier"
- rm -f "bin/libbreakgen.so"
- rm -f "bin/libyjpagent-linux.so"
- rm -f "bin/rubymine.vmoptions"
- rm -rf "lib/libpty/linux/x86"
- fi
+ # Remove bin/libs if architecture doesn't match
+ if [[ $CARCH = 'i686' ]]; then
+ rm -f bin/fsnotifier64
+ rm -f bin/libbreakgen64.so
+ rm -f bin/libyjpagent-linux64.so
+ rm -f bin/rubymine64.vmoptions
+ rm -rf lib/libpty/linux/x86_64
+ fi
+ if [[ $CARCH = 'x86_64' ]]; then
+ rm -f bin/fsnotifier
+ rm -f bin/libbreakgen.so
+ rm -f bin/libyjpagent-linux.so
+ rm -f bin/rubymine.vmoptions
+ rm -rf lib/libpty/linux/x86
+ fi
}
package() {
- cd "${srcdir}"
- [ $CARCH == "x86_64" ] && SUFFIX=64
+ [ $CARCH == "x86_64" ] && SUFFIX=64
- #Pre-packaged program files
- install -d -m 755 "${pkgdir}/usr/share"
- cp -a "${srcdir}/${_pkgname}-${pkgver}" "${pkgdir}/usr/share/${pkgname}"
+ # Pre-packaged program files
+ install -dm0755 "${pkgdir}/usr/share"
+ cp -a "${_pkgname}-${pkgver}" "${pkgdir}/usr/share/${pkgname}"
- #Desktop application
- install -Dm644 "${pkgdir}/usr/share/${pkgname}/bin/RMlogo.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
- install -Dm644 "rubymine.desktop" "${pkgdir}/usr/share/applications/rubymine.desktop"
- install -d -m 755 "${pkgdir}/usr/bin"
- ln -s "/usr/share/${pkgname}/bin/${pkgname}.sh" "${pkgdir}/usr/bin/jetbrains-${pkgname}"
+ # Desktop application
+ install -Dm0644 "${pkgdir}/usr/share/${pkgname}/bin/RMlogo.svg" \
+ "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
+ install -Dm0644 rubymine.desktop \
+ "${pkgdir}/usr/share/applications/rubymine.desktop"
+ install -dm0755 "${pkgdir}/usr/bin"
+ ln -s "/usr/share/${pkgname}/bin/${pkgname}.sh" \
+ "${pkgdir}/usr/bin/jetbrains-${pkgname}"
- #License
- install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- find "$srcdir/$_pkgname-$pkgver/license/" -type f -exec \
- install -Dm644 '{}' "$pkgdir/usr/share/licenses/$pkgname/" \;
+ # License
+ install -dm0755 "$pkgdir/usr/share/licenses/$pkgname"
+ find "$_pkgname-$pkgver/license/" -type f -exec \
+ install -Dm0644 '{}' "$pkgdir/usr/share/licenses/$pkgname/" \;
- #Java config
- sed -i 's/lcd/on/' "${pkgdir}/usr/share/rubymine/bin/rubymine${SUFFIX}.vmoptions"
- echo "-Dswing.aatext=true" >> "${pkgdir}/usr/share/rubymine/bin/rubymine${SUFFIX}.vmoptions"
+ # Java config
+ sed -i 's/lcd/on/' \
+ "${pkgdir}/usr/share/rubymine/bin/rubymine${SUFFIX}.vmoptions"
+ echo "-Dswing.aatext=true" >> \
+ "${pkgdir}/usr/share/rubymine/bin/rubymine${SUFFIX}.vmoptions"
}
+
+# vim: set ts=2 sw=2 et: