summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGleb Sinyavsky2015-11-09 03:49:53 +0300
committerGleb Sinyavsky2015-11-09 03:49:53 +0300
commit4e4c3435de930fc116803eedc3c8146f198b0018 (patch)
tree7510d148722e16f0a8a7d7e84b57c3d32db97d15
downloadaur-4e4c3435de930fc116803eedc3c8146f198b0018.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD75
-rw-r--r--rubymine.desktop10
-rw-r--r--rubymine.install25
4 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3edad7ebb4de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = rubymine7
+ pkgdesc = Ruby and Rails IDE with the full stack of essential developer tools. 7 version
+ pkgver = 7.1.4
+ pkgrel = 1
+ url = https://www.jetbrains.com/ruby/
+ install = rubymine.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = java-environment
+ depends = desktop-file-utils
+ depends = gtk-update-icon-cache
+ optdepends = ruby: Ruby run/debug support
+ conflicts = rubymine
+ options = !strip
+ source = https://download.jetbrains.com/ruby/RubyMine-7.1.4.tar.gz
+ source = rubymine.desktop
+ source = rubymine.install
+ sha256sums = 9b5aa6099bca2dc6a1eefd1633ef6d0424a8767c95ca189bc18774a5222b8b43
+ sha256sums = 72df0e7c605caf7b6c98e9335f4eee9c8bfe8fcc24523634fd8c1ebe019534d6
+ sha256sums = 7ecadddf2b315b22df3a5c7b90e18be7ea69e2a0d869ee18bf0e031b2c508f76
+
+pkgname = rubymine7
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8f1a2ed8491
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: Gleb Sinyavsky <zhulik dot gleb at gmail dot com>
+# Contributor: Mario Finelli <mario dot finelli at yahoo dot com>
+# Contributor: Tom Richards <tom at tomrichards dot net>
+# Contributor: Alexsandr Pavlov <kidoz at mail dot ru>
+# Contributor: Ernie Brodeur <ebrodeur at ujami dotnet>
+# Contributor: Rogof <fake dot bios at gmail dot com>
+# Contributor: m4.rc0 <m4 dot rc0 at o2 dot pl>
+
+pkgname=rubymine7
+_pkgname=RubyMine
+pkgver=7.1.4
+pkgrel=1
+pkgdesc="Ruby and Rails IDE with the full stack of essential developer tools. 7 version"
+arch=('i686' 'x86_64')
+options=(!strip)
+url="https://www.jetbrains.com/ruby/"
+license=('custom')
+depends=('java-environment' 'desktop-file-utils' 'gtk-update-icon-cache')
+optdepends=('ruby: Ruby run/debug support')
+install=rubymine.install
+source=(https://download.jetbrains.com/ruby/${_pkgname}-${pkgver}.tar.gz
+ rubymine.desktop
+ rubymine.install)
+sha256sums=('9b5aa6099bca2dc6a1eefd1633ef6d0424a8767c95ca189bc18774a5222b8b43'
+ '82b7415d984ac1e7b0ace8b0ce4de8d33471483077d7fab4ca75a835384beaf2'
+ '678ec0038b54e760d19c8967d92eb1781da12e7a1818faff3f489e65330dbba9')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ # Remove junk
+ rm "build.txt"
+ rm "Install-Linux-tar.txt"
+
+ #Remove non-linux libs
+ rm -rf "lib/libpty/macosx"
+ rm -rf "lib/libpty/win"
+
+ #Remove bin/libs if architecture doesn't match
+ if [[ $CARCH = 'i686' ]]; then
+ rm -f "bin/fsnotifier64"
+ rm -f "bin/libbreakgen64.so"
+ rm -f "bin/libyjpagent-linux64.so"
+ rm -f "bin/rubymine64.vmoptions"
+ rm -rf "lib/libpty/linux/x86_64"
+ fi
+ if [[ $CARCH = 'x86_64' ]]; then
+ rm -f "bin/fsnotifier"
+ rm -f "bin/libbreakgen.so"
+ rm -f "bin/libyjpagent-linux.so"
+ rm -f "bin/rubymine.vmoptions"
+ rm -rf "lib/libpty/linux/x86"
+ fi
+}
+
+package() {
+ cd "${srcdir}"
+ [ $CARCH == "x86_64" ] && SUFFIX=64
+
+ #Pre-packaged program files
+ install -d -m 755 "${pkgdir}/usr/share"
+ cp -a "${srcdir}/${_pkgname}-${pkgver}" "${pkgdir}/usr/share/${pkgname}"
+
+ #Desktop application
+ install -Dm644 "${pkgdir}/usr/share/${pkgname}/bin/RMlogo.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
+ install -Dm644 "rubymine.desktop" "${pkgdir}/usr/share/applications/rubymine.desktop"
+ install -d -m 755 "${pkgdir}/usr/bin"
+ ln -s "/usr/share/${pkgname}/bin/rubymine.sh" "${pkgdir}/usr/bin/jetbrains-${pkgname}"
+
+ #License
+ install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/license/${_pkgname}_license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+
+ #Java config
+ sed -i 's/lcd/on/' "${pkgdir}/usr/share/${pkgname}/bin/rubymine${SUFFIX}.vmoptions"
+ echo "-Dswing.aatext=true" >> "${pkgdir}/usr/share/${pkgname}/bin/rubymine${SUFFIX}.vmoptions"
+}
diff --git a/rubymine.desktop b/rubymine.desktop
new file mode 100644
index 000000000000..c3d36e566347
--- /dev/null
+++ b/rubymine.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=RubyMine7
+Comment=Ruby and Rails IDE with the full stack of essential developer tools. 7 version
+GenericName=Ruby and Rails IDE with the full stack of essential developer tools. 7 version
+Exec=/usr/bin/jetbrains-rubymine7
+Icon=rubymine7
+Terminal=false
+Type=Application
+Categories=Development;IDE;Ruby
+StartupWMClass=jetbrains-rubymine
diff --git a/rubymine.install b/rubymine.install
new file mode 100644
index 000000000000..ca78fbd37153
--- /dev/null
+++ b/rubymine.install
@@ -0,0 +1,25 @@
+_notice() {
+ echo
+ echo "You can buy a license after the 30-day trial period here:"
+ echo "http://www.jetbrains.com/ruby/buy/"
+ echo "For licensing information please read /usr/share/licenses/rubymine7/license.txt"
+}
+
+_update_desktop() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_install() {
+ _update_desktop
+ _notice
+}
+
+post_upgrade() {
+ _update_desktop
+ _notice
+}
+
+post_remove() {
+ _update_desktop
+}