summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEivind Eide2019-06-11 07:02:38 +0200
committerEivind Eide2019-06-11 07:02:38 +0200
commit3eee29eb16ddc4acfd1bfb141d1bac41c6dd6bbe (patch)
tree7054a2007490e5fb2d0997cfb5efabd019097237
parent1946ae9ba59b173c3bf7fbbbcfb0c3668bcafff1 (diff)
downloadaur-3eee29eb16ddc4acfd1bfb141d1bac41c6dd6bbe.tar.gz
GitHub fork. Works with current Linux.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 22 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff9db3777b66..e1ddf0cd84bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Wed Jul 19 13:21:46 UTC 2017
pkgbase = rubyripper
pkgdesc = Secure audiodisc ripper
- pkgver = 0.6.2
- pkgrel = 10
+ pkgver = 0.7.0rc2
+ pkgrel = 1
url = http://code.google.com/p/rubyripper/
arch = any
license = GPL3
@@ -20,8 +18,12 @@ pkgbase = rubyripper
optdepends = vorbisgain: Ogg Vorbis ReplayGain support
optdepends = normalize: Normalization support
optdepends = cdrdao: Advanced TOC analysis
- source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/rubyripper/rubyripper-0.6.2.tar.bz2
- sha256sums = 817a800ba9a8eca9a8130fad861913c8ebdc4ec3011135e216b41007fc989ebb
+ optdepends = sox: Correct pre-emphasis with sox
+ optdepends = wavpack: WavPack encoding support
+ optdepends = opus-tools: Opus encoding support
+ optdepends = neroaacenc-bin: Nero AAC encoding support
+ source = https://github.com/bleskodev/rubyripper/archive/v0.7.0rc2.tar.gz
+ sha256sums = 977089c4a262936f9acf82ad1ab5932de97523ba31b61b5ccc1279a94eaea6ae
pkgname = rubyripper
diff --git a/PKGBUILD b/PKGBUILD
index 92c10303f72b..67c5502d4cf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer:
-# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
-# Contributor: Maxime Gauduin <alucryd@gmail.com>
-# Contributor: Dave Reisner <dreisner@archlinux.org>
-# Contributor: Alexander Fehr <pizzapunk gmail com>
+# Maintainer: Eivind Eide <xenofil AT gmail DOT com>
+# Contributor: Alexander F Rødseth <xyproto AT archlinux DOT org>
+# Contributor: Maxime Gauduin <alucryd AT gmail DOT com>
+# Contributor: Dave Reisner <dreisner AT archlinux DOT org>
+# Contributor: Alexander Fehr <pizzapunk AT gmail DOT com>
pkgname=rubyripper
-pkgver=0.6.2
-pkgrel=10
+pkgver=0.7.0rc2
+pkgrel=1
pkgdesc='Secure audiodisc ripper'
arch=('any')
url='http://code.google.com/p/rubyripper/'
@@ -21,9 +21,13 @@ optdepends=('ruby-gtk2: GTK+ GUI'
'mp3gain: MP3 ReplayGain support'
'vorbisgain: Ogg Vorbis ReplayGain support'
'normalize: Normalization support'
- 'cdrdao: Advanced TOC analysis')
-source=("https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/rubyripper/rubyripper-$pkgver.tar.bz2")
-sha256sums=('817a800ba9a8eca9a8130fad861913c8ebdc4ec3011135e216b41007fc989ebb')
+ 'cdrdao: Advanced TOC analysis'
+ 'sox: Correct pre-emphasis with sox'
+ 'wavpack: WavPack encoding support'
+ 'opus-tools: Opus encoding support'
+ 'neroaacenc-bin: Nero AAC encoding support')
+source=("https://github.com/bleskodev/rubyripper/archive/v$pkgver.tar.gz")
+sha256sums=('977089c4a262936f9acf82ad1ab5932de97523ba31b61b5ccc1279a94eaea6ae')
build() {
cd "${pkgname}-${pkgver}"