summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEivind Eide2020-01-03 00:37:59 +0100
committerEivind Eide2020-01-03 00:37:59 +0100
commitdb9ef45a52e895afa57da3c31eb9f3c5e5ae683e (patch)
treebe97febc8191da206b7aaa3bd5d9541b2352ba1a
parentec7a08a5157039b8163e70102989797ea04b1d67 (diff)
downloadaur-db9ef45a52e895afa57da3c31eb9f3c5e5ae683e.tar.gz
Improve PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa7ca53b8c29..2bff146a1e7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rubyripper
pkgdesc = Secure audiodisc ripper
pkgver = 0.7.0rc2
- pkgrel = 2
+ pkgrel = 3
url = http://code.google.com/p/rubyripper/
arch = any
license = GPL3
@@ -23,7 +23,7 @@ pkgbase = rubyripper
optdepends = wavpack: WavPack encoding support
optdepends = opus-tools: Opus encoding support
optdepends = neroaacenc-bin: Nero AAC encoding support
- source = https://github.com/bleskodev/rubyripper/archive/v0.7.0rc2.tar.gz
+ source = rubyripper-0.7.0rc2.tar.gz::https://github.com/bleskodev/rubyripper/archive/v0.7.0rc2.tar.gz
sha256sums = 977089c4a262936f9acf82ad1ab5932de97523ba31b61b5ccc1279a94eaea6ae
pkgname = rubyripper
diff --git a/PKGBUILD b/PKGBUILD
index 3998a8ba62a4..667da95244db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=rubyripper
pkgver=0.7.0rc2
-pkgrel=2
+pkgrel=3
pkgdesc='Secure audiodisc ripper'
arch=('any')
url='http://code.google.com/p/rubyripper/'
@@ -26,7 +26,7 @@ optdepends=('ruby-gtk2: GTK+ GUI'
'wavpack: WavPack encoding support'
'opus-tools: Opus encoding support'
'neroaacenc-bin: Nero AAC encoding support')
-source=("https://github.com/bleskodev/rubyripper/archive/v$pkgver.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bleskodev/rubyripper/archive/v${pkgver}.tar.gz")
sha256sums=('977089c4a262936f9acf82ad1ab5932de97523ba31b61b5ccc1279a94eaea6ae')
build() {
@@ -37,7 +37,8 @@ build() {
}
package() {
- make DESTDIR="$pkgdir" -C "$pkgname-$pkgver" install
+
+ make DESTDIR="${pkgdir}" -C "${pkgname}-${pkgver}" install
}
# vim: ts=2 sw=2 et: