summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Popov2015-07-02 01:44:48 +0200
committerDenys Popov2015-07-02 01:44:48 +0200
commit90e39ee8e12e0a2a43366373020991fb33966caa (patch)
treee8540ac9ff00aa7407bc7d2c96c3af6c114fb93d
downloadaur-90e39ee8e12e0a2a43366373020991fb33966caa.tar.gz
Import from old AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--arch-install13
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16b5f3b20357
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rukbi
+ pkgdesc = Alternative Ukrainian and Russian keyboard layouts with miscellaneous useful typographic characters, including Ilya Birman’s layout
+ pkgver = 3.5
+ pkgrel = 2
+ url = http://besisland.name/rukbi
+ install = arch-install
+ arch = any
+ license = GPLv3
+ depends = xkeyboard-config
+ depends = python
+ source = http://rukbi.googlecode.com/files/rukbi-3.5.tar.bz2
+ md5sums = 58741c7318f99d8157675c454eff213c
+ sha1sums = 4195f1fd81535897a82f1f5a8aa2a851ccfe72a7
+ sha256sums = ddcd326976039c4b85424da09c01b5db89188321e9d86831716d077c566ea8b0
+
+pkgname = rukbi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cade2012b0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Denys Popov <besisland@besisland.name>
+pkgname=rukbi
+pkgver=3.5
+pkgrel=2
+pkgdesc="Alternative Ukrainian and Russian keyboard layouts with miscellaneous useful typographic characters, including Ilya Birman’s layout"
+url="http://besisland.name/rukbi"
+arch=("any")
+license=("GPLv3")
+depends=("xkeyboard-config" "python")
+source=("http://rukbi.googlecode.com/files/$pkgname-$pkgver.tar.bz2")
+md5sums=('58741c7318f99d8157675c454eff213c')
+sha1sums=('4195f1fd81535897a82f1f5a8aa2a851ccfe72a7')
+sha256sums=('ddcd326976039c4b85424da09c01b5db89188321e9d86831716d077c566ea8b0')
+install=arch-install
+
+check() {
+ cd "$srcdir"
+ test/test
+}
+
+package() {
+ local xkbdir="$pkgdir/usr/share/X11/xkb"
+ cd "$srcdir"
+
+ install -d $xkbdir/symbols $xkbdir/rules
+ install -m 0644 symbols/* $xkbdir/symbols/
+
+ install -d $xkbdir/rukbi/install $xkbdir/rukbi/symbols $xkbdir/rukbi/rules
+ install -m 0755 install/* $xkbdir/rukbi/install/
+ install -m 0644 symbols/* $xkbdir/rukbi/symbols/
+ install -m 0644 rules/* $xkbdir/rukbi/rules/
+}
diff --git a/arch-install b/arch-install
new file mode 100644
index 000000000000..87ce7942b457
--- /dev/null
+++ b/arch-install
@@ -0,0 +1,13 @@
+# Maintainer: Denys Popov <besisland@besisland.name>
+# rukbi install file
+
+post_install() {
+ printf "\n"
+ printf "==> You have to run '/usr/share/X11/xkb/rukbi/install/install' as root in order to patch the xkeyboard-config.\n"
+ printf "==> If the xkeyboard-config package were reinstalled, run this script again.\n"
+ printf "\n"
+}
+
+post_upgrade() {
+ post_install
+}