summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Laurén2018-09-13 22:42:46 +0300
committerSamuel Laurén2018-09-13 22:42:46 +0300
commit39be4f8f1a5aaed58e42bf17d75c704011f88488 (patch)
treee442303d83bff412bfd1ccfd4df1b84a98cca9aa
downloadaur-39be4f8f1a5aaed58e42bf17d75c704011f88488.tar.gz
run-or-raise 0.3.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6bcd85f64d74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = run-or-raise
+ pkgdesc = Utility for launching applications or focusing their windows
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/Soft/run-or-raise
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ makedepends = cargo
+ makedepends = python
+ depends = libxcb
+ source = https://github.com/Soft/run-or-raise/archive/0.3.1.tar.gz
+ sha256sums = c5e913aa95e30d76eb3c62a1f6b219bac884753a27d5487fbb69fe4d1208b06c
+
+pkgname = run-or-raise
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd5ec5f3c99a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Samuel Laurén <samuel.lauren@iki.fi>
+pkgname=run-or-raise
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Utility for launching applications or focusing their windows"
+arch=("x86_64")
+url="https://github.com/Soft/run-or-raise"
+license=("GPL3")
+depends=("libxcb")
+makedepends=("rust" "cargo" "python")
+source=("https://github.com/Soft/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=("c5e913aa95e30d76eb3c62a1f6b219bac884753a27d5487fbb69fe4d1208b06c")
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ install -D -m755 -D target/release/${pkgname} "$pkgdir/usr/bin/${pkgname}"
+ install -D -m644 -D man/${pkgname}.1 "$pkgdir/usr/share/man/man1/${pkgname}.1"
+}
+
+# vim:set ts=2 sw=2 et: