summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2020-05-26 21:31:30 +0300
committerMantas Mikulėnas2020-05-26 21:32:06 +0300
commit2ea59dee72f6f987c5b6a1704729e704d29f6e82 (patch)
treebf1bea4e6df7f036dc963f4c539e435859e61828
parent765417cd34f364cd6fd92468ddd5695232c36155 (diff)
downloadaur-2ea59dee72f6f987c5b6a1704729e704d29f6e82.tar.gz
bring back OpenSSL 1.0 workaround
Did someone accidentally revert the build system to last year?
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD23
2 files changed, 25 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc2e6ea1e504..1c40f24dfaf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = runescape-launcher
pkgdesc = RuneScape Game Client (NXT)
pkgver = 2.2.7
- pkgrel = 1
+ pkgrel = 2
url = https://www.runescape.com/
- install = install.sh
arch = x86_64
license = custom
+ makedepends = gcc
depends = cairo
depends = gcc-libs
depends = gdk-pixbuf2
@@ -17,6 +17,7 @@ pkgbase = runescape-launcher
depends = openssl
depends = pango
depends = sdl2
+ depends = openssl-1.0
source = runescape-launcher_2.2.7_Release::https://content.runescape.com/downloads/ubuntu/dists/trusty/Release
source = runescape-launcher_2.2.7_Release.gpg::https://content.runescape.com/downloads/ubuntu/dists/trusty/Release.gpg
validpgpkeys = AAC9264309E4D717441DB9527373B12CE03BEB4B
diff --git a/PKGBUILD b/PKGBUILD
index 3e041464b6e6..b38d4dd8c5c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=runescape-launcher
pkgver=2.2.7
-pkgrel=1
+pkgrel=2
pkgdesc="RuneScape Game Client (NXT)"
arch=(x86_64)
license=(custom)
@@ -21,6 +21,8 @@ depends=(
openssl
pango
sdl2
+ # XXX: temporary
+ openssl-1.0
)
source=("${pkgname}_${pkgver}_Release::https://content.runescape.com/downloads/ubuntu/dists/trusty/Release"
"${pkgname}_${pkgver}_Release.gpg::https://content.runescape.com/downloads/ubuntu/dists/trusty/Release.gpg")
@@ -41,6 +43,10 @@ install="install.sh"
# avoid caching in makepkg!
SRCDEST=$startdir
+# XXX: temporary LD_PRELOAD
+unset install
+makedepends=(gcc)
+
_verify_repo() {
if (( SKIPPGPCHECK )); then
return 0
@@ -111,6 +117,14 @@ prepare() {
bsdtar xvf ../data.tar.xz
}
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # XXX: temporary
+ echo 'int SSLv3_client_method() { return -1; }' > libfakesslv3.c
+ gcc -shared -o libfakesslv3.so libfakesslv3.c
+}
+
package() {
cd "$srcdir/$pkgname-$pkgver"
@@ -122,6 +136,13 @@ package() {
#sed -i 's,/usr/share/games,/usr/lib,' "$pkgdir"/usr/bin/runescape-launcher
install -Dm0644 copyright "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ # XXX: temporary
+ install -Dm0644 libfakesslv3.so "$pkgdir"/usr/share/games/runescape-launcher/libfakesslv3.so
+ sed -i '1aexport LD_PRELOAD=/usr/share/games/runescape-launcher/libfakesslv3.so' \
+ "$pkgdir"/usr/bin/runescape-launcher
+ sed -i '1aif [ -e ~/Jagex/launcher/rs2client ]; then echo "Removing file capabilities from ~/Jagex/launcher/rs2client"; truncate -r ~/Jagex/launcher/rs2client{,}; fi' \
+ "$pkgdir"/usr/bin/runescape-launcher
}
# vim: ft=sh:ts=4:sw=4:et:nowrap